summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJanne Heß2016-01-15 20:00:18 +0100
committerJanne Heß2016-01-15 20:00:18 +0100
commit513c41c74262f958d9bdb76947d6560fb4272f74 (patch)
treed0eb66d4a702373080b349dab515cb8d8379e92c
downloadaur-513c41c74262f958d9bdb76947d6560fb4272f74.tar.gz
Intial commit
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD33
-rw-r--r--zfsmond.service12
3 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4b59e692aa68
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+# Generated by mksrcinfo v8
+# Fri Jan 15 18:59:53 UTC 2016
+pkgbase = zfsmond-git
+ pkgdesc = Tiny ZFS Web Interface written in AngularJS and Flask Restful
+ pkgver = 90cc056
+ pkgrel = 1
+ url = https://github.com/FireDrunk/ZFSmond
+ arch = any
+ license = GPL
+ depends = python2-pyudev
+ depends = python2-pysmart
+ depends = python2-flask
+ depends = python2-flask-restful
+ depends = python2-enum34
+ depends = python2-cffi
+ depends = python2-libzfs-git
+ source = git://github.com/FireDrunk/ZFSmond
+ source = zfsmond.service
+ sha256sums = SKIP
+ sha256sums = 27f05cd919b88ee691c6a1fd95c51ced540bbbd96b1ba3458c17149cc8fd25da
+
+pkgname = zfsmond-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..edf1c52c1e7a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Janne Heß <jannehess@gmail.com>
+
+# Contributor: Janne Heß <jannehess@gmail.com>
+
+pkgname=zfsmond-git
+pkgver=90cc056
+pkgrel=1
+pkgdesc='Tiny ZFS Web Interface written in AngularJS and Flask Restful'
+url='https://github.com/FireDrunk/ZFSmond'
+license=('GPL')
+depends=('python2-pyudev' 'python2-pysmart' 'python2-flask' 'python2-flask-restful' 'python2-enum34' 'python2-cffi' 'python2-libzfs-git')
+source=('git://github.com/FireDrunk/ZFSmond'
+'zfsmond.service')
+sha256sums=('SKIP'
+ '27f05cd919b88ee691c6a1fd95c51ced540bbbd96b1ba3458c17149cc8fd25da')
+arch=('any')
+
+pkgver() {
+ cd "${srcdir}/ZFSmond"
+ git describe --always
+}
+
+build() {
+ # Ugly hack to decrease verbosity
+ sed -i 's/app.debug = True/app.debug = False'$"\n"'import logging'$"\n"'logging.getLogger("werkzeug").setLevel(logging.ERROR)/g' "${srcdir}/ZFSmond/main.py"
+}
+
+package() {
+ cd "${srcdir}/ZFSmond"
+ install -Dm755 main.py "${pkgdir}/usr/share/webapps/ZFSmond/main.py"
+ install -Dm644 "${srcdir}/zfsmond.service" "${pkgdir}/usr/lib/systemd/system/zfsmond.service"
+ cp -Rp models static "${pkgdir}/usr/share/webapps/ZFSmond"
+}
diff --git a/zfsmond.service b/zfsmond.service
new file mode 100644
index 000000000000..11a73cfb79dc
--- /dev/null
+++ b/zfsmond.service
@@ -0,0 +1,12 @@
+[Unit]
+Description=Tiny ZFS Web Interface
+After=elasticsearch.service
+
+[Service]
+Type=simple
+WorkingDirectory=/usr/share/webapps/ZFSmond
+ExecStart=/usr/bin/python2 main.py
+
+[Install]
+WantedBy=multi-user.target
+