summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJason T. Bradshaw2016-07-08 17:25:59 -0500
committerJason T. Bradshaw2016-07-08 17:25:59 -0500
commit30153680009d4a87b5724e00c772dbca58ce5154 (patch)
treecc434bf4ed5910cd4f3351c0e8fc7b4ce87691ce
downloadaur-30153680009d4a87b5724e00c772dbca58ce5154.tar.gz
Release 2.0.0-beta2
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD59
2 files changed, 75 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..506316481469
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = zfsnap
+ pkgdesc = A portable, performant script to make rolling ZFS snapshots easy.
+ pkgver = 2.0.0beta2
+ pkgrel = 1
+ url = http://www.zfsnap.org/
+ arch = any
+ license = BSD
+ depends = sh
+ optdepends = bash: for the corresponding completions,
+ optdepends = tcsh: for the corresponding completions,
+ optdepends = zsh: for the corresponding completions
+ source = https://github.com/zfsnap/zfsnap/archive/v2.0.0-beta2.tar.gz
+ md5sums = 5a933d1f84cb880eb8463868ea1845ec
+
+pkgname = zfsnap
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f2dd3a6494f4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,59 @@
+# Maintainer: Jason T. Bradshaw <jasontbradshaw@gmail.com>
+pkgname=zfsnap
+pkgver=2.0.0beta2
+pkgrel=1
+pkgdesc='A portable, performant script to make rolling ZFS snapshots easy.'
+arch=('any')
+url='http://www.zfsnap.org/'
+license=('BSD')
+depends=('sh')
+optdepends=(
+ 'bash: for the corresponding completions',
+ 'tcsh: for the corresponding completions',
+ 'zsh: for the corresponding completions'
+)
+source=(https://github.com/zfsnap/zfsnap/archive/v2.0.0-beta2.tar.gz)
+md5sums=('5a933d1f84cb880eb8463868ea1845ec')
+
+# Put the hyphen back between the end of the version and the start of the tag.
+_hyphenated_pkgver="$(echo "${pkgver}" | sed -r 's/([0-9])([a-z])/\1-\2/')"
+_pkgdirver="${pkgname}-${_hyphenated_pkgver}"
+
+package() {
+ cd "${srcdir}/${_pkgdirver}"
+
+ # Script files.
+ mkdir -p "${pkgdir}/usr/share/${pkgname}"
+ cp -r share/zfsnap/* "${pkgdir}/usr/share/${pkgname}/"
+
+ # Main executable.
+ mkdir -p "${pkgdir}/usr/bin"
+ install --mode='755' "sbin/zfsnap.sh" "${pkgdir}/usr/bin/${pkgname}"
+
+ # Man page.
+ mkdir -p "${pkgdir}/usr/share/man/man8"
+ install --mode='644' 'man/man8/zfsnap.8' "${pkgdir}/usr/share/man/man8/${pkgname}.8"
+
+ # License. Necessary since BSD is unique per-project.
+ mkdir -p "${pkgdir}/usr/share/licenses/${pkgname}"
+ install --mode='644' 'LICENSE' "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
+ # `bash` completions.
+ mkdir -p "${pkgdir}/usr/share/bash-completion/completions"
+ install --mode='644' \
+ 'completion/zfsnap-completion.bash' \
+ "${pkgdir}/usr/share/bash-completion/completions/${pkgname}"
+
+ # `zsh` completions.
+ mkdir -p "${pkgdir}/usr/share/zsh/site-functions"
+ install --mode='644' \
+ "completion/zfsnap-completion.bash" \
+ "${pkgdir}/usr/share/zsh/site-functions/_${pkgname}"
+
+ # NOTE: I have no idea where to put `tcsh` completions :(
+}
+
+check() {
+ cd "${_pkgdirver}/tests"
+ ./run.sh
+}