summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMa Jiehong2015-06-09 22:14:50 +0200
committerMa Jiehong2015-06-09 22:14:50 +0200
commite259fb64395caaa54d7347c846d0968984978f27 (patch)
tree30453602246833731be75c258f5d16784844f6f5
downloadaur-e259fb64395caaa54d7347c846d0968984978f27.tar.gz
Import of zhudi to AUR 4
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD21
-rw-r--r--zhudi.install10
3 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..779a63af228c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by makepkg 4.2.1
+# Tue Jun 9 20:12:17 UTC 2015
+pkgbase = zhudi
+ pkgdesc = Python/GTK3+ GUI to Chinese -English-French-German dictionnaries (CEDICT, CFDICT, HanDeDict, ChE-Dicc…). It also provides pinyin and zhuyin pronunciaton as well as a sentence segmentation utility.
+ pkgver = 1.6
+ pkgrel = 1
+ url = https://github.com/Jiehong/Zhudi
+ install = zhudi.install
+ arch = any
+ license = GPL3
+ depends = python
+ depends = python-gobject
+ depends = pygobject-devel
+ depends = gobject-introspection
+ depends = pango
+ conflicts = zhudi
+ source = zhudi::git://github.com/Jiehong/Zhudi
+ md5sums = SKIP
+
+pkgname = zhudi
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..21f412230da8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: murchik <mixturchik@gmail.com>
+pkgname=zhudi
+pkgver=1.6
+pkgrel=1
+pkgdesc="Python/GTK3+ GUI to Chinese -English-French-German dictionnaries (CEDICT, CFDICT, HanDeDict, ChE-Dicc…). It also provides pinyin and zhuyin pronunciaton as well as a sentence segmentation utility."
+arch=('any')
+url="https://github.com/Jiehong/Zhudi"
+license=('GPL3')
+depends=('python' 'python-gobject' 'pygobject-devel' 'gobject-introspection' 'pango')
+conflicts=('zhudi')
+install=zhudi.install
+changelog=
+source=(zhudi::git://github.com/Jiehong/Zhudi)
+md5sums=('SKIP')
+
+package() {
+ cd "$srcdir/$pkgname"
+ git checkout $pkgver
+ msg "Installation in progress…"
+ python setup.py install --prefix=/usr --root="$pkgdir/" --optimize=1
+}
diff --git a/zhudi.install b/zhudi.install
new file mode 100644
index 000000000000..f17f0424e644
--- /dev/null
+++ b/zhudi.install
@@ -0,0 +1,10 @@
+post_install() {
+ echo "You might want to install a dictionary along with Zhudi"
+ echo "You can download the CFDICT at: http://www.chine-informations.com/chinois/open/CFDICT/cfdict.zip"
+ echo "Or you can download the CEDICT at: http://www.mdbg.net/chindict/export/cedict/cedict_1_0_ts_utf-8_mdbg.zip"
+ echo "After having downloaded a dictionary, place it in ~/.zhudi. You can now launch:"
+ echo "cd ~/.zhudi"
+ echo "zhudi -s cedict.u8"
+ echo "You will, then, be able to enjoy zhudi by simply launching it:"
+ echo "zhudi"
+}