summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTechcable2022-08-23 21:08:07 -0700
committerTechcable2022-08-23 21:12:54 -0700
commit2fa5955d7e5e1c8ab9ea0ad539d37cf6aab407dd (patch)
treefbedf3ea19c7482ecef77725fb885d7b02b327e1
parent5e21c2cd75a9ee49d48376d91af4e64db2f38dc7 (diff)
downloadaur-2fa5955d7e5e1c8ab9ea0ad539d37cf6aab407dd.tar.gz
Add hello.zig to index to fix failing check()
This was caused by a bad .gitignore file which explicitly included files (instead of it's usual role of excluding files). Thanks to @legendary-cookie for noticing this. Now I switched to the traditional form that excludes files (so this specific git issue should not happen again). Bump pkgver to indicate
-rw-r--r--.SRCINFO2
-rw-r--r--.gitignore12
-rw-r--r--PKGBUILD2
-rw-r--r--hello.zig9
4 files changed, 15 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b34191427c69..96a8b99b8e08 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = zig-dev-bin
pkgdesc = A general-purpose programming language and toolchain for maintaining robust, optimal, and reusable software
pkgver = 0.10.0_dev.3659+e5e6eb983
- pkgrel = 1
+ pkgrel = 2
epoch = 1
url = https://ziglang.org/
arch = x86_64
diff --git a/.gitignore b/.gitignore
index b52a9be84147..a8cb0255bf89 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,9 +1,5 @@
-*
-!.gitignore
-!PKGBUILD
-!*.patch
-!*.install
-!*.sysusers
-!.SRCINFO
+zig-cache
-!check.sh
+/src
+/pkg
+*.pkg.tar*
diff --git a/PKGBUILD b/PKGBUILD
index 66a5a2747acb..d53f3d58ebca 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,7 +10,7 @@ pkgname=zig-dev-bin
epoch=1
# NOTE: Hyphen -> underscore
pkgver=0.10.0_dev.3659+e5e6eb983
-pkgrel=1
+pkgrel=2
pkgdesc="A general-purpose programming language and toolchain for maintaining robust, optimal, and reusable software"
arch=('x86_64' 'aarch64')
url="https://ziglang.org/"
diff --git a/hello.zig b/hello.zig
new file mode 100644
index 000000000000..9b93b1132c80
--- /dev/null
+++ b/hello.zig
@@ -0,0 +1,9 @@
+const std = @import("std");
+
+pub fn main() !void {
+ std.debug.print("Hello World\n", .{});
+}
+
+test "tester" {
+ try std.testing.expectEqual(4 + 5, 9);
+}