summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarc Tiehuis2017-09-10 18:27:10 +1200
committerMarc Tiehuis2017-09-10 18:27:10 +1200
commit8ee61011087c513b16cc11e0fb9528d67b843df2 (patch)
tree175ee521b17693a080a52697f82e812f5ad219ea
parentabbdc06c2ab429a519ed97ab59a71d93da757d9e (diff)
downloadaur-8ee61011087c513b16cc11e0fb9528d67b843df2.tar.gz
Add patch to handle new LLVM issues around inline
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD11
2 files changed, 11 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 52ab5538a03e..4d336bb6c3fc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,13 @@
pkgbase = zig-git
pkgdesc = a programming language prioritizing robustness, optimality, and clarity
pkgver = 0.0.0r1474.6aa04c4
- pkgrel = 2
+ pkgrel = 3
url = http://ziglang.org
arch = i686
arch = x86_64
license = MIT
makedepends = cmake
+ makedepends = curl
depends = llvm
depends = clang
depends = lld
diff --git a/PKGBUILD b/PKGBUILD
index 6e4bc7fa8972..74805d0eff94 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,13 @@
pkgname=zig-git
pkgver=0.0.0r1474.6aa04c4
-pkgrel=2
+pkgrel=3
pkgdesc="a programming language prioritizing robustness, optimality, and clarity"
arch=('i686' 'x86_64')
url='http://ziglang.org'
license=('MIT')
depends=('llvm' 'clang' 'lld')
-makedepends=('cmake')
+makedepends=('cmake' 'curl')
provides=(zig)
conflicts=(zig)
# We pin this commit since it is the last supported by llvm-4 before the switch
@@ -16,6 +16,13 @@ conflicts=(zig)
source=("git://github.com/zig-lang/zig.git#commit=6aa04c422bae89c50e1289e1ca51cd4d414debb7")
md5sums=('SKIP')
+prepare() {
+ cd "$srcdir/$provides"
+ # This patch is required due to how LLVM inlines and it not always working.
+ curl https://gist.githubusercontent.com/tiehuis/294797c898892a2612e9e3246574defc/raw/42f02982c8371b710e24d9246711b3a505c35c57/remove_inline.patch > remove_inline.patch
+ git apply remove_inline.patch
+}
+
pkgver() {
cd "$srcdir/$provides"
printf "0.0.0r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"