summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarc Tiehuis2017-09-17 10:55:00 +1200
committerMarc Tiehuis2017-09-17 10:55:00 +1200
commitc6319db10de16b452eedef7c7462e96fcf5c3f90 (patch)
treebce181945b595e9352149e25e7555bf7b1c5234d
parent8ee61011087c513b16cc11e0fb9528d67b843df2 (diff)
downloadaur-c6319db10de16b452eedef7c7462e96fcf5c3f90.tar.gz
Update to llvm5 and latest git version
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD19
2 files changed, 8 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4d336bb6c3fc..d66a8ade684f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,17 @@
pkgbase = zig-git
pkgdesc = a programming language prioritizing robustness, optimality, and clarity
- pkgver = 0.0.0r1474.6aa04c4
- pkgrel = 3
+ pkgver = 0.0.0r1594.dcc5f24
+ pkgrel = 1
url = http://ziglang.org
arch = i686
arch = x86_64
license = MIT
makedepends = cmake
- makedepends = curl
depends = llvm
depends = clang
- depends = lld
provides = zig
conflicts = zig
- source = git://github.com/zig-lang/zig.git#commit=6aa04c422bae89c50e1289e1ca51cd4d414debb7
+ source = git://github.com/zig-lang/zig.git
md5sums = SKIP
pkgname = zig-git
diff --git a/PKGBUILD b/PKGBUILD
index 74805d0eff94..7d6a48ff166d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,19 @@
# Maintainer: Marc Tiehuis <marctiehuis at gmail.com>
pkgname=zig-git
-pkgver=0.0.0r1474.6aa04c4
-pkgrel=3
+pkgver=0.0.0r1594.dcc5f24
+pkgrel=1
pkgdesc="a programming language prioritizing robustness, optimality, and clarity"
arch=('i686' 'x86_64')
url='http://ziglang.org'
license=('MIT')
-depends=('llvm' 'clang' 'lld')
-makedepends=('cmake' 'curl')
+depends=('llvm' 'clang')
+makedepends=('cmake')
provides=(zig)
conflicts=(zig)
-# We pin this commit since it is the last supported by llvm-4 before the switch
-# to llvm-5.
-source=("git://github.com/zig-lang/zig.git#commit=6aa04c422bae89c50e1289e1ca51cd4d414debb7")
+source=("git://github.com/zig-lang/zig.git")
md5sums=('SKIP')
-prepare() {
- cd "$srcdir/$provides"
- # This patch is required due to how LLVM inlines and it not always working.
- curl https://gist.githubusercontent.com/tiehuis/294797c898892a2612e9e3246574defc/raw/42f02982c8371b710e24d9246711b3a505c35c57/remove_inline.patch > remove_inline.patch
- git apply remove_inline.patch
-}
-
pkgver() {
cd "$srcdir/$provides"
printf "0.0.0r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"