summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHenry Nelson2018-09-28 13:50:17 -0400
committerHenry Nelson2018-09-28 13:50:17 -0400
commit0a0bfd1b0a9b0b7b6fe9f96ffc17f71735bf74e3 (patch)
tree10c6644b4ffb9858b5eb229d57f433c9b102f5ce
downloadaur-0a0bfd1b0a9b0b7b6fe9f96ffc17f71735bf74e3.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD23
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bf9d4f7aa989
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = zig-static
+ pkgdesc = robust, optimal, and clear programming language
+ pkgver = 0.3.0
+ pkgrel = 1
+ url = https://ziglang.org/
+ arch = x86_64
+ license = MIT
+ provides = zig
+ conflicts = zig
+ source = https://ziglang.org/download/0.3.0/zig-linux-x86_64-0.3.0.tar.xz
+ md5sums = 38bc421ef7b6e6966ae67bc3cb01b3c5
+
+pkgname = zig-static
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..946dd63e7cfe
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Henry Nelson <hcnelson99@gmail.com>
+pkgname=zig-static
+pkgver=0.3.0
+pkgrel=1
+epoch=
+pkgdesc="robust, optimal, and clear programming language"
+arch=('x86_64')
+url="https://ziglang.org/"
+license=('MIT')
+depends=()
+makedepends=()
+provides=('zig')
+conflicts=('zig')
+source=("https://ziglang.org/download/0.3.0/zig-linux-x86_64-$pkgver.tar.xz")
+md5sums=('38bc421ef7b6e6966ae67bc3cb01b3c5')
+
+package() {
+ cd "$srcdir/zig-linux-x86_64-$pkgver"
+ install -D zig "$pkgdir/usr/bin/zig"
+ install -D LICENSE "$pkgdir/usr/share/licenses/zig/LICENSE"
+ cp -R lib "$pkgdir/usr"
+ install -D langref.html "$pkgdir/usr/share/doc/zig/langref.html"
+}