summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHenry Nelson2020-04-13 18:40:11 -0400
committerHenry Nelson2020-04-13 18:40:11 -0400
commit9f3c5645baaf30fd8c407ee995b5dd1067811070 (patch)
tree6eacfcfa0e651c4085087ddf1859ea48c3d662be
parent622ff505fea630217c3527f1a8ac6de9d0f51e18 (diff)
downloadaur-9f3c5645baaf30fd8c407ee995b5dd1067811070.tar.gz
Update to zig 0.6
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD9
2 files changed, 8 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f7ce3eefb4b1..dd8572fef1c4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = zig-static
pkgdesc = robust, optimal, and clear programming language
- pkgver = 0.5.0
+ pkgver = 0.6.0
pkgrel = 1
url = https://ziglang.org/
arch = x86_64
license = MIT
provides = zig
conflicts = zig
- source = https://ziglang.org/download/0.5.0/zig-linux-x86_64-0.5.0.tar.xz
- md5sums = 18617395245d6695e48986cc46015be9
+ source = https://ziglang.org/download/0.6.0/zig-linux-x86_64-0.6.0.tar.xz
+ md5sums = 1af42a1ab03215c039d0863b5a320dd7
pkgname = zig-static
diff --git a/PKGBUILD b/PKGBUILD
index d0267b5e807f..c691bdc5c9c0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Henry Nelson <hcnelson99@gmail.com>
pkgname=zig-static
-pkgver=0.5.0
+pkgver=0.6.0
pkgrel=1
epoch=
pkgdesc="robust, optimal, and clear programming language"
@@ -12,12 +12,13 @@ makedepends=()
provides=('zig')
conflicts=('zig')
source=("https://ziglang.org/download/$pkgver/zig-linux-x86_64-$pkgver.tar.xz")
-md5sums=('18617395245d6695e48986cc46015be9')
+md5sums=('1af42a1ab03215c039d0863b5a320dd7')
package() {
cd "$srcdir/zig-linux-x86_64-$pkgver"
install -D zig "$pkgdir/usr/bin/zig"
install -D LICENSE "$pkgdir/usr/share/licenses/zig/LICENSE"
- cp -R lib "$pkgdir/usr"
- install -D langref.html "$pkgdir/usr/share/doc/zig/langref.html"
+ cp -r lib "$pkgdir/usr"
+ install -d "$pkgdir/usr/share/doc"
+ cp -r doc "$pkgdir/usr/share/doc/zig"
}