summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbuckket2020-03-24 15:26:29 +0100
committerbuckket2020-03-24 15:26:29 +0100
commitf0b834f9a9d16a9162468507f8582b6a54b8c158 (patch)
treeef564bf88bb9075b5e64954dcfc5ee61a25ece54
parent730857a0abe7d9f51187833f154d3e1824678997 (diff)
downloadaur-f0b834f9a9d16a9162468507f8582b6a54b8c158.tar.gz
Adopting package, minor changes
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD32
2 files changed, 22 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a07ac378f47a..fe1691115ceb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,16 @@
pkgbase = zigbee2mqtt-git
- pkgdesc = A Zigbee to MQTT bridge for domotic devices.
- pkgver = 1.5.1.r0.gac3b924
+ pkgdesc = A Zigbee to MQTT bridge
+ pkgver = 1.12.0.r0.g840b9d9
pkgrel = 1
url = https://www.zigbee2mqtt.io
arch = any
- license = GPLv3
- makedepends = npm
+ license = GPL3
makedepends = git
- depends = nodejs>=10.0
+ depends = nodejs>=10.0,
+ depends = npm
optdepends = cc-tool: To flash Texas Instruments CC2531 debugger
optdepends = mosquitto: MQTT broker
+ provides = zigbee2mqtt
conflicts = zigbee2mqtt
backup = opt/zigbee2mqtt/data/configuration.yaml
source = zigbee2mqtt::git+https://github.com/Koenkk/zigbee2mqtt.git
diff --git a/PKGBUILD b/PKGBUILD
index 5bcbae12d89a..4fa11f0894c3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,16 @@
+# Maintainer: buckket <felix@buckket.org>
+
_pkgname=zigbee2mqtt
pkgname=zigbee2mqtt-git
-pkgver=1.7.1.r0.gb459c35
+pkgver=1.12.0.r0.g840b9d9
pkgrel=1
-pkgdesc="A Zigbee to MQTT bridge for domotic devices."
+pkgdesc="A Zigbee to MQTT bridge"
arch=('any')
url="https://www.zigbee2mqtt.io"
-license=('GPLv3')
+license=('GPL3')
depends=('nodejs>=10.0', 'npm')
conflicts=('zigbee2mqtt')
+provides=('zigbee2mqtt')
makedepends=('git')
optdepends=(
'cc-tool: To flash Texas Instruments CC2531 debugger'
@@ -17,27 +20,24 @@ source=(
'zigbee2mqtt.service'
'zigbee2mqtt.sysusers'
'zigbee2mqtt.tmpfiles')
-sha256sums=(
- 'SKIP'
- '831ce970669d29ba2db208bec8245c97e80540981dd23276bba10a9b7b699e1b'
- 'bf3e49cfb86df460b4db16b280839dc7f0c73fbfd29ea6d86040f711606abf65'
- '5861e6e25350b32fc81cf1a43802470e8ff033a019cba4d28b3bd48c6cb5ddf6')
+sha256sums=('SKIP'
+ '831ce970669d29ba2db208bec8245c97e80540981dd23276bba10a9b7b699e1b'
+ 'bf3e49cfb86df460b4db16b280839dc7f0c73fbfd29ea6d86040f711606abf65'
+ '5861e6e25350b32fc81cf1a43802470e8ff033a019cba4d28b3bd48c6cb5ddf6')
backup=('opt/zigbee2mqtt/data/configuration.yaml')
pkgver() {
-
- cd zigbee2mqtt
+ cd "${_pkgname}"
git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/v//'
-
}
package() {
-
- cd "$_pkgname"
+ cd "${_pkgname}"
npm install --cache "${srcdir}/npm-cache" --user root
install -d -m 650 "${pkgdir}/opt/${_pkgname}"
cp -dpr --no-preserve=ownership "${srcdir}/${_pkgname}/" "${pkgdir}/opt/"
- install -Dm644 "$srcdir/${_pkgname}.service" "${pkgdir}/usr/lib/systemd/system/${_pkgname}.service"
- install -Dm644 "$srcdir/${_pkgname}.sysusers" "$pkgdir/usr/lib/sysusers.d/${_pkgname}.conf"
- install -Dm644 "$srcdir/${_pkgname}.tmpfiles" "$pkgdir/usr/lib/tmpfiles.d/${_pkgname}.conf"
+ install -Dm644 "${srcdir}/${_pkgname}.service" "${pkgdir}/usr/lib/systemd/system/${_pkgname}.service"
+ install -Dm644 "${srcdir}/${_pkgname}.sysusers" "${pkgdir}/usr/lib/sysusers.d/${_pkgname}.conf"
+ install -Dm644 "${srcdir}/${_pkgname}.tmpfiles" "${pkgdir}/usr/lib/tmpfiles.d/${_pkgname}.conf"
}
+