summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Gentilucci2019-06-12 12:54:20 -0600
committerAlex Gentilucci2019-06-12 12:54:20 -0600
commit9965ecae042a72260cc99499b8a6680318908156 (patch)
treec345d0c3bf31ee923fa92c03f05063b4a1a57f49
parent0c1e484ccd1f75214717f6df96760dae7a29981a (diff)
downloadaur-9965ecae042a72260cc99499b8a6680318908156.tar.gz
Updated commit since zillib was updated.
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD14
2 files changed, 11 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 906c544f78aa..0d00aa7145fe 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,18 @@
pkgbase = zilf
- pkgdesc = A set of tools for working with the ZIL interactive fiction language, including a compiler, assembler, disassembler, and game library.
+ pkgdesc = Tools for working with the ZIL fiction language, including a compiler and assembler
pkgver = 0.8
- pkgrel = 4
+ pkgrel = 5
url = https://bitbucket.org/jmcgrew/zilf
arch = any
license = GPL
depends = mono
options = !strip
source = https://bitbucket.org/jmcgrew/zilf/downloads/zilf-0.8.zip
- source = https://bitbucket.org/jmcgrew/zilf/get/399382d7f96d.zip
+ source = https://bitbucket.org/jmcgrew/zilf/get/27ad7d9cf7af.zip
source = zapf.sh
source = zilf.sh
sha512sums = 15ac5054b64a7a9a1674a85a82d30d7599c446f5cdf47cebb9a48c5b0488ffd61d716b83754347ab79c789bab494e1271dd477e76f6cb47853a0958efbc8bfcf
- sha512sums = 216dc611372e4b6a6e0029dca50f0282bcd299e6d375d3c87328be7b8d89c12cb05220b79782ed9cf194620c411513580d7c7a89df5b88136b158fc33735e84b
+ sha512sums = 7a663b95d93cf4cd8d426d1a9b94592ecbf02c1e4f91eed97bfdae0be28bbe8ba5efbb4e34939a356cb9a8b3d2fab91bff0c354ce902c80ff521117833d828ff
sha512sums = d32f99285b021a558315b0c334af7f764410fe0c14a76a684af8a8f741b10b2f1cf98642b7a127ad25a57881fd57802c7d5918d151bc0c831809df1b4a06870c
sha512sums = cfa4c5381eff3bc18840dd842260f803501dc0a584356b116e4f9b383a1b3a42ec8664e7fefac91df386cb611975b5250e56e6b69e5bbab0515947cc65103223
diff --git a/PKGBUILD b/PKGBUILD
index c191afabe940..1e5dd6cd5b46 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,10 @@
# Maintainer: Alex Gentilucci <alexander.gentilucci@gmail.com>
-_commit=399382d7f96d
+_commit=27ad7d9cf7af
pkgname=zilf
pkgver=0.8
-pkgrel=4
+pkgrel=5
epoch=
-pkgdesc="A set of tools for working with the ZIL interactive fiction language, including a compiler, assembler, disassembler, and game library."
+pkgdesc="Tools for working with the ZIL fiction language, including a compiler and assembler"
arch=(any)
url="https://bitbucket.org/jmcgrew/zilf"
license=('GPL')
@@ -15,15 +15,15 @@ source=("https://bitbucket.org/jmcgrew/zilf/downloads/zilf-$pkgver.zip"
"zapf.sh"
"zilf.sh")
sha512sums=('15ac5054b64a7a9a1674a85a82d30d7599c446f5cdf47cebb9a48c5b0488ffd61d716b83754347ab79c789bab494e1271dd477e76f6cb47853a0958efbc8bfcf'
- '216dc611372e4b6a6e0029dca50f0282bcd299e6d375d3c87328be7b8d89c12cb05220b79782ed9cf194620c411513580d7c7a89df5b88136b158fc33735e84b'
- 'd32f99285b021a558315b0c334af7f764410fe0c14a76a684af8a8f741b10b2f1cf98642b7a127ad25a57881fd57802c7d5918d151bc0c831809df1b4a06870c'
- 'cfa4c5381eff3bc18840dd842260f803501dc0a584356b116e4f9b383a1b3a42ec8664e7fefac91df386cb611975b5250e56e6b69e5bbab0515947cc65103223')
+ '7a663b95d93cf4cd8d426d1a9b94592ecbf02c1e4f91eed97bfdae0be28bbe8ba5efbb4e34939a356cb9a8b3d2fab91bff0c354ce902c80ff521117833d828ff'
+ 'd32f99285b021a558315b0c334af7f764410fe0c14a76a684af8a8f741b10b2f1cf98642b7a127ad25a57881fd57802c7d5918d151bc0c831809df1b4a06870c'
+ 'cfa4c5381eff3bc18840dd842260f803501dc0a584356b116e4f9b383a1b3a42ec8664e7fefac91df386cb611975b5250e56e6b69e5bbab0515947cc65103223')
package() {
install -d -m 755 "${pkgdir}/usr/lib/zilf"
install -d -m 755 "${pkgdir}/usr/lib/zilf/library"
cp -dpr --no-preserve=ownership "${srcdir}/$pkgname-$pkgver/bin/"* "${pkgdir}/usr/lib/zilf"
- cp -dpr --no-preserve=ownership "${srcdir}/jmcgrew-zilf-$_commit/Library/"* "${pkgdir}/usr/lib/zilf/library/"
+ cp -dpr --no-preserve=ownership "${srcdir}/jmcgrew-zilf-$_commit/zillib/"* "${pkgdir}/usr/lib/zilf/library/"
chmod ugo+x "${pkgdir}/usr/lib/zilf/zilf.exe"
chmod ugo+x "${pkgdir}/usr/lib/zilf/zapf.exe"
install -D -m 755 "${srcdir}/zilf.sh" "${pkgdir}/usr/bin/zilf"