summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Gentilucci2019-08-24 09:37:59 -0600
committerAlex Gentilucci2019-08-24 09:37:59 -0600
commita1e1f9ce0ef438f8590ac9cb42fad90cdb2f5097 (patch)
tree359ccc5bdf12d757775e29bc8ab14894b290d4b6
parent4d437bfc66f7190fad229311b3eace10d2a79b2a (diff)
downloadaur-a1e1f9ce0ef438f8590ac9cb42fad90cdb2f5097.tar.gz
Incremented version and automated updates
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD40
-rw-r--r--zapf.sh2
-rw-r--r--zilf.sh2
4 files changed, 28 insertions, 35 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e75618d6cff8..8ba176c77614 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,15 @@
pkgbase = zilf
pkgdesc = Tools for working with the ZIL fiction language, including a compiler and assembler
- pkgver = 0.8
- pkgrel = 7
+ pkgver = 0.9.0
+ pkgrel = 0
url = https://bitbucket.org/jmcgrew/zilf
- arch = any
+ arch = x86_64
license = GPL
- depends = mono
options = !strip
- source = https://bitbucket.org/jmcgrew/zilf/downloads/zilf-0.8.zip
- source = https://bitbucket.org/jmcgrew/zilf/get/50348c10e92e.zip
- source = zapf.sh
- source = zilf.sh
- sha512sums = 15ac5054b64a7a9a1674a85a82d30d7599c446f5cdf47cebb9a48c5b0488ffd61d716b83754347ab79c789bab494e1271dd477e76f6cb47853a0958efbc8bfcf
- sha512sums = 81e76021896b176dba585a79c47ce64e94687c9aaeda52c79c3d234cf9b7200005ea859adf83c1d9c14ef032d6c488072403c56374c967ddec674fe28a349911
- sha512sums = d32f99285b021a558315b0c334af7f764410fe0c14a76a684af8a8f741b10b2f1cf98642b7a127ad25a57881fd57802c7d5918d151bc0c831809df1b4a06870c
- sha512sums = cfa4c5381eff3bc18840dd842260f803501dc0a584356b116e4f9b383a1b3a42ec8664e7fefac91df386cb611975b5250e56e6b69e5bbab0515947cc65103223
+ source = https://bitbucket.org/jmcgrew/zilf/downloads/zilf-0.9.0-linux-x64.tar.gz
+ source = https://bitbucket.org/jmcgrew/zilf/downloads
+ sha512sums = afc1c54d4fa8d4910ce61c3619ccfc9cb8fd16bdb70cdc0c2ddbebbce4e3abe9064f46ae29e358060d9a80c827a9d73062c9ef89df371f61e151bf16777216e9
+ sha512sums = SKIP
pkgname = zilf
diff --git a/PKGBUILD b/PKGBUILD
index 89f2dc6aa46d..d951012b9df4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,33 @@
# Maintainer: Alex Gentilucci <alexander.gentilucci@gmail.com>
-_commit=50348c10e92e
pkgname=zilf
-pkgver=0.8
-pkgrel=7
+pkgver=0.9.0
+pkgrel=0
epoch=
pkgdesc="Tools for working with the ZIL fiction language, including a compiler and assembler"
-arch=(any)
+arch=('x86_64')
url="https://bitbucket.org/jmcgrew/zilf"
license=('GPL')
-depends=('mono')
options=('!strip')
-source=("https://bitbucket.org/jmcgrew/zilf/downloads/zilf-$pkgver.zip"
- "https://bitbucket.org/jmcgrew/zilf/get/$_commit.zip"
- "zapf.sh"
- "zilf.sh")
-sha512sums=('15ac5054b64a7a9a1674a85a82d30d7599c446f5cdf47cebb9a48c5b0488ffd61d716b83754347ab79c789bab494e1271dd477e76f6cb47853a0958efbc8bfcf'
- '81e76021896b176dba585a79c47ce64e94687c9aaeda52c79c3d234cf9b7200005ea859adf83c1d9c14ef032d6c488072403c56374c967ddec674fe28a349911'
- 'd32f99285b021a558315b0c334af7f764410fe0c14a76a684af8a8f741b10b2f1cf98642b7a127ad25a57881fd57802c7d5918d151bc0c831809df1b4a06870c'
- 'cfa4c5381eff3bc18840dd842260f803501dc0a584356b116e4f9b383a1b3a42ec8664e7fefac91df386cb611975b5250e56e6b69e5bbab0515947cc65103223')
+source=("https://bitbucket.org/jmcgrew/zilf/downloads/zilf-$pkgver-linux-x64.tar.gz"
+ "https://bitbucket.org/jmcgrew/zilf/downloads")
+sha512sums=('afc1c54d4fa8d4910ce61c3619ccfc9cb8fd16bdb70cdc0c2ddbebbce4e3abe9064f46ae29e358060d9a80c827a9d73062c9ef89df371f61e151bf16777216e9'
+ 'SKIP')
+
+prepare() {
+ _commit=$(grep -oE "get\/([0-9a-fA-F]+)" downloads | cut -c 5-)
+ curl -O "https://bitbucket.org/jmcgrew/zilf/get/$_commit.zip"
+ unzip -q "$_commit.zip" -d "$srcdir"
+}
package() {
+ _commit=$(grep -oE "get\/([0-9a-fA-F]+)" downloads | cut -c 5-)
install -d -m 755 "$pkgdir/usr/lib/zilf"
install -d -m 755 "$pkgdir/usr/lib/zilf/library"
- cp -dpr --no-preserve=ownership "$srcdir/$pkgname-$pkgver/bin/"* "$pkgdir/usr/lib/zilf"
- cp -dpr --no-preserve=ownership "$srcdir/jmcgrew-zilf-$_commit/zillib/"* "$pkgdir/usr/lib/zilf/library/"
- chmod ugo+x "$pkgdir/usr/lib/zilf/zilf.exe"
- chmod ugo+x "$pkgdir/usr/lib/zilf/zapf.exe"
- install -D -m 755 "$srcdir/zilf.sh" "$pkgdir/usr/bin/zilf"
- install -D -m 755 "$srcdir/zapf.sh" "$pkgdir/usr/bin/zapf"
+ cp -dpr --no-preserve=ownership "$srcdir/$pkgname-$pkgver-linux-x64/bin/"* "$pkgdir/usr/lib/zilf"
+ cp -dpr --no-preserve=ownership "$srcdir/jmcgrew-zilf-$_commit/zillib/"* "$pkgdir/usr/lib/zilf/library/"
+ chmod ugo+x "$pkgdir/usr/lib/zilf/zilf"
+ chmod ugo+x "$pkgdir/usr/lib/zilf/zapf"
+ mkdir -p ${pkgdir}/usr/bin
+ ln -sf "/usr/lib/zilf/zilf" "$pkgdir/usr/bin/zilf"
+ ln -sf "/usr/lib/zilf/zapf" "$pkgdir/usr/bin/zapf"
}
diff --git a/zapf.sh b/zapf.sh
deleted file mode 100644
index 7dd3efc64fb9..000000000000
--- a/zapf.sh
+++ /dev/null
@@ -1,2 +0,0 @@
-#!/bin/sh
-mono /usr/lib/zilf/zapf.exe "$@"
diff --git a/zilf.sh b/zilf.sh
deleted file mode 100644
index 737e0b7734e0..000000000000
--- a/zilf.sh
+++ /dev/null
@@ -1,2 +0,0 @@
-#!/bin/sh
-mono /usr/lib/zilf/zilf.exe "$@"