summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Gentilucci2019-04-18 12:24:13 -0600
committerAlex Gentilucci2019-04-18 12:24:13 -0600
commita6c53d11885ce0750d444efeb20e0b41f727f448 (patch)
tree2b64b9b3a1a4b51a1d0efa59aa5a432ba492715a
parent90a52e16346f84907efa0f3429f0a4583ba3693b (diff)
downloadaur-a6c53d11885ce0750d444efeb20e0b41f727f448.tar.gz
Forgot to copy library to /usr/lib/zilf
-rw-r--r--.SRCINFO2
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD4
3 files changed, 6 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5cc643c85c27..ebdf64880e7b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = zilf
pkgdesc = A set of tools for working with the ZIL interactive fiction language, including a compiler, assembler, disassembler, and game library.
pkgver = 0.8
- pkgrel = 1
+ pkgrel = 2
url = https://bitbucket.org/jmcgrew/zilf
arch = any
license = GPL
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4ac9c0125d91
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+*.zip
+*.pkg.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index db475bcbe61a..0dde67ce93e5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Alex Gentilucci <alexander.gentilucci@gmail.com>
pkgname=zilf
pkgver=0.8
-pkgrel=1
+pkgrel=2
epoch=
pkgdesc="A set of tools for working with the ZIL interactive fiction language, including a compiler, assembler, disassembler, and game library."
arch=(any)
@@ -18,7 +18,9 @@ sha512sums=('15ac5054b64a7a9a1674a85a82d30d7599c446f5cdf47cebb9a48c5b0488ffd61d7
package() {
install -d -m 755 "${pkgdir}/usr/lib/zilf"
+ install -d -m 755 "${pkgdir}/usr/lib/zilf/library"
cp -dpr --no-preserve=ownership "${srcdir}/$pkgname-$pkgver/bin/"* "${pkgdir}/usr/lib/zilf"
+ cp -dpr --no-preserve=ownership "${srcdir}/$pkgname-$pkgver/library/"* "${pkgdir}/usr/lib/zilf/library/"
install -D -m755 "${srcdir}/zilf.sh" "${pkgdir}/usr/bin/zilf"
install -D -m755 "${srcdir}/zapf.sh" "${pkgdir}/usr/bin/zapf"
}