summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsl1pkn072015-11-22 02:51:32 +0100
committersl1pkn072015-11-22 02:51:32 +0100
commitef176c926cca4b68635345897cd2f3db2960451d (patch)
tree6d3c1689a07b40a0b4275717fae9ff402bac8669
downloadaur-ef176c926cca4b68635345897cd2f3db2960451d.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD41
3 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..305751051589
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = zimg-git
+ pkgdesc = Scaling, colorspace conversion, and dithering library. include VapourSynth plugin (deprecated soon(?)). (GIT version)
+ pkgver = 2.0.1.22.g1aa2811
+ pkgrel = 1
+ url = http://forum.doom9.org/showthread.php?t=171334
+ arch = i686
+ arch = x86_64
+ license = custom:WTFPL
+ makedepends = git
+ depends = vapoursynth
+ provides = zimg
+ provides = vapoursynth-plugin-zimg
+ conflicts = zimg
+ conflicts = vapoursynth-plugin-zimg
+ source = git+https://github.com/sekrit-twc/zimg.git
+ sha1sums = SKIP
+
+pkgname = zimg-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4420e499a75c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+pkgname=zimg-git
+pkgver=2.0.1.22.g1aa2811
+pkgrel=1
+pkgdesc="Scaling, colorspace conversion, and dithering library. include VapourSynth plugin (deprecated soon(?)). (GIT version)"
+arch=('i686' 'x86_64')
+url='http://forum.doom9.org/showthread.php?t=171334'
+license=('custom:WTFPL')
+depends=('vapoursynth')
+makedepends=('git')
+provides=('zimg' 'vapoursynth-plugin-zimg')
+conflicts=('zimg' 'vapoursynth-plugin-zimg')
+source=('git+https://github.com/sekrit-twc/zimg.git')
+sha1sums=('SKIP')
+
+pkgver() {
+ cd zimg
+ echo "$(git describe --long --tags | tr - . | sed 's|release.||g')"
+}
+
+prepare() {
+ cd zimg
+ ./autogen.sh
+}
+
+build() {
+ cd zimg
+ ./configure --prefix=/usr \
+ --enable-x86simd
+ make
+}
+
+package(){
+ make -C zimg DESTDIR="${pkgdir}" install
+ install -d "${pkgdir}/usr/lib/vapoursynth"
+ ln -s ../zimg/vszimg.so "${pkgdir}/usr/lib/vapoursynth/libvszimg.so"
+
+ install -Dm644 zimg/COPYING "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
+ install -Dm644 zimg/doc/vszimg/vszimg.txt "${pkgdir}/usr/share/doc/vapoursynth/plugins/zimg/vszimg.txt"
+}