summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrei Pozolotin2016-07-19 22:34:28 +0000
committerAndrei Pozolotin2016-07-19 22:34:28 +0000
commit99a23a40def0577daad96fb2097e9c8954163b53 (patch)
tree3adfaf8c808a7f0c7ab6199c0e0599d8938c963a
parenta9d51d018980bd9d249a3c3adb367e886c076432 (diff)
downloadaur-99a23a40def0577daad96fb2097e9c8954163b53.tar.gz
M .SRCINFO
M PKGBUILD A zincer.conf M zincer.service M zincer.sh
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD5
-rwxr-xr-xzincer.conf10
-rw-r--r--zincer.service20
-rwxr-xr-xzincer.sh6
5 files changed, 26 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ba0d42e8c44f..12bfaa7d42d1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = zinc
pkgdesc = Zinc is a stand-alone version of sbt's incremental compiler
- pkgver = 0.3.9
+ pkgver = 0.3.11
pkgrel = 1
url = https://github.com/typesafehub/zinc
arch = any
@@ -9,12 +9,14 @@ pkgbase = zinc
provides = zinc
conflicts = zinc-git
options = !strip
- source = http://downloads.typesafe.com/zinc/0.3.9/zinc-0.3.9.tgz
+ source = http://downloads.typesafe.com/zinc/0.3.11/zinc-0.3.11.tgz
source = zincer.sh
+ source = zincer.conf
source = zincer.service
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
+ md5sums = SKIP
pkgname = zinc
diff --git a/PKGBUILD b/PKGBUILD
index c14a541393a5..3721bb437b58 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
pkgdesc="Zinc is a stand-alone version of sbt's incremental compiler"
pkgname="zinc"
-pkgver=0.3.9
+pkgver=0.3.11
pkgrel=1
url="https://github.com/typesafehub/zinc"
arch=('any')
@@ -11,12 +11,14 @@ conflicts=('zinc-git')
source=(
"http://downloads.typesafe.com/zinc/$pkgver/zinc-$pkgver.tgz"
"zincer.sh" # server launcher
+ "zincer.conf" # service env vars
"zincer.service" # systemd service
)
md5sums=(
'SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
)
options=('!strip')
@@ -45,6 +47,7 @@ package() {
cp -a "$source/." "$target/"
install -D -m755 zincer.sh "$target/zincer.sh"
+ install -D -m644 zincer.conf "$pkgdir/etc/conf.d/zincer.conf"
install -D -m644 zincer.service "$pkgdir/usr/lib/systemd/system/zincer.service"
mkdir -p $pkgdir/usr/bin
diff --git a/zincer.conf b/zincer.conf
new file mode 100755
index 000000000000..a39ca9d1a608
--- /dev/null
+++ b/zincer.conf
@@ -0,0 +1,10 @@
+
+ZINC_HOME=/opt/zinc
+ZINC_PORT=3030
+ZINC_TIMEOUT=0
+
+JAVA_EXEC=/usr/bin/java
+JAVA_META=512m
+JAVA_HEAP=1024m
+JAVA_CODE=256m
+JAVA_STACK=1m
diff --git a/zincer.service b/zincer.service
index 6a58782a925b..618835bfafcf 100644
--- a/zincer.service
+++ b/zincer.service
@@ -4,21 +4,13 @@ Description=Zinc Server
Documentation=https://github.com/typesafehub/zinc
[Service]
-#
-Environment=ZINC_HOME=/opt/zinc
-Environment=ZINC_PORT=3030
-Environment=ZINC_TIMEOUT=0
-#
-Environment=JAVA_EXEC=java
-Environment=JAVA_META=512m
-Environment=JAVA_HEAP=1024m
-Environment=JAVA_CODE=256m
-Environment=JAVA_STACK=1m
-#
-ExecStart=/bin/bash ${ZINC_HOME}/zincer.sh
-#
+EnvironmentFile=/etc/conf.d/zincer.conf
+StandardOutput=syslog
+StandardError=syslog
+SyslogIdentifier=zincer
+ExecStart=/opt/zincer.sh
Restart=on-failure
-RestartSec=1s
+RestartSec=3s
[Install]
WantedBy=multi-user.target
diff --git a/zincer.sh b/zincer.sh
index f846eb25c42d..8d65c59f2456 100755
--- a/zincer.sh
+++ b/zincer.sh
@@ -1,7 +1,5 @@
#!/bin/bash
-# zinc server launcher
-
[[ $ZINC_HOME ]] || ZINC_HOME=/opt/zinc
[[ $ZINC_PORT ]] || ZINC_PORT=3030
[[ $ZINC_TIMEOUT ]] || ZINC_TIMEOUT=0
@@ -12,7 +10,7 @@
[[ $JAVA_CODE ]] || JAVA_CODE=256m
[[ $JAVA_STACK ]] || JAVA_STACK=1m
-command="\
+COMMAND="\
\
$JAVA_EXEC \
\
@@ -38,4 +36,4 @@ com.typesafe.zinc.Nailgun \
$ZINC_PORT $ZINC_TIMEOUT \
"
-exec $command
+exec $COMMAND