summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonio Rojas2021-05-08 09:32:55 +0000
committerAntonio Rojas2021-05-08 09:32:55 +0000
commitb2c540cebf08c29b44208c69e45d7f36c869b0d7 (patch)
tree03e356da7c512cd37656f26415f427483e03273d
downloadaur-b2c540cebf08c29b44208c69e45d7f36c869b0d7.tar.gz
Dropped from repos
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD34
-rw-r--r--zinnia-gcc6.patch21
3 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..634ddae3c83f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = zinnia
+ pkgdesc = Simple, customizable and portable online hand recognition system based on Support Vector Machines
+ pkgver = 0.06
+ pkgrel = 6
+ url = http://zinnia.sourceforge.net/
+ arch = x86_64
+ license = BSD
+ depends = gcc-libs
+ source = https://downloads.sourceforge.net/project/zinnia/zinnia/0.06/zinnia-0.06.tar.gz
+ source = zinnia-gcc6.patch
+ sha256sums = ece3af93f937282971634fd81d3e997f848e8cfa958220e26a4564ca064ac20b
+ sha256sums = f27cc4bd687d4c66525f744315c53caa537f1998dd546ffba9ef337e033854e6
+
+pkgname = zinnia
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..153152663f14
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Felix Yan <felixonmars@archlinux.org>
+# Contributor: Humbert Julien <julroy67 [AT] gmail.com>
+
+pkgname=zinnia
+pkgver=0.06
+pkgrel=6
+pkgdesc="Simple, customizable and portable online hand recognition system based on Support Vector Machines"
+arch=('x86_64')
+url="http://zinnia.sourceforge.net/"
+license=('BSD')
+depends=('gcc-libs')
+source=("https://downloads.sourceforge.net/project/$pkgname/$pkgname/$pkgver/$pkgname-$pkgver.tar.gz"
+ zinnia-gcc6.patch)
+sha256sums=('ece3af93f937282971634fd81d3e997f848e8cfa958220e26a4564ca064ac20b'
+ 'f27cc4bd687d4c66525f744315c53caa537f1998dd546ffba9ef337e033854e6')
+
+prepare() {
+ cd $pkgname-$pkgver
+ patch -p1 -i ../zinnia-gcc6.patch # Fix build with GCC 6 (Debian)
+}
+
+build() {
+ cd $pkgname-$pkgver
+
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd $pkgname-$pkgver
+
+ make DESTDIR="$pkgdir" install
+ install -Dm644 "$srcdir/$pkgname-$pkgver/COPYING" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
diff --git a/zinnia-gcc6.patch b/zinnia-gcc6.patch
new file mode 100644
index 000000000000..399fe9f8dff2
--- /dev/null
+++ b/zinnia-gcc6.patch
@@ -0,0 +1,21 @@
+--- a/trainer.cpp
++++ b/trainer.cpp
+@@ -93,7 +93,7 @@ class TrainerImpl: public Trainer {
+
+ public:
+ bool add(const Character &character) {
+- const std::string y = character.value();
++ std::string y = character.value();
+ CHECK_FALSE(!y.empty()) << "input character is empty";
+ Features features;
+ CHECK_FALSE(features.read(character)) << "cannot read character: " << y;
+@@ -103,7 +103,7 @@ class TrainerImpl: public Trainer {
+ if (!fn) {
+ return false;
+ }
+- x_.push_back(std::make_pair<std::string, FeatureNode *>(y, fn));
++ x_.push_back(std::make_pair(y, fn));
+ return true;
+ }
+
+