summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOrhun Parmaksız2023-01-07 23:27:47 +0300
committerOrhun Parmaksız2023-01-07 23:27:47 +0300
commit51ac529cb9638643c63efb108ee3877a83951187 (patch)
tree733f88936ecddf9420ea3f7caa3d4dbf7f02a6f6
downloadaur-51ac529cb9638643c63efb108ee3877a83951187.tar.gz
Initial upload: zip-password-finder-git 0.5.0.r4.gc1b5cb1-1
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD43
2 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..08c0bd72066a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = zip-password-finder-git
+ pkgdesc = Find the password of protected ZIP files (git)
+ pkgver = 0.5.0.r4.gc1b5cb1
+ pkgrel = 1
+ url = https://github.com/agourlay/zip-password-finder
+ arch = x86_64
+ license = Apache
+ makedepends = cargo
+ makedepends = git
+ depends = bzip2
+ provides = zip-password-finder
+ conflicts = zip-password-finder
+ options = !lto
+ source = git+https://github.com/agourlay/zip-password-finder
+ sha512sums = SKIP
+
+pkgname = zip-password-finder-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2a4434fbd58a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: orhun <orhunparmaksiz@gmail.com>
+# https://github.com/orhun/pkgbuilds
+
+pkgname=zip-password-finder-git
+pkgver=0.5.0.r4.gc1b5cb1
+pkgrel=1
+pkgdesc="Find the password of protected ZIP files (git)"
+arch=('x86_64')
+url="https://github.com/agourlay/zip-password-finder"
+license=('Apache')
+depends=('bzip2')
+makedepends=('cargo' 'git')
+conflicts=("${pkgname%-git}")
+provides=("${pkgname%-git}")
+source=("git+${url}")
+sha512sums=('SKIP')
+options=('!lto')
+
+pkgver() {
+ cd "${pkgname%-git}"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd "${pkgname%-git}"
+ cargo fetch --locked --target "$CARCH-unknown-linux-gnu"
+}
+
+build() {
+ cd "${pkgname%-git}"
+ cargo build --release --frozen
+}
+
+check() {
+ cd "${pkgname%-git}"
+ cargo test --frozen
+}
+
+package() {
+ cd "${pkgname%-git}"
+ install -Dm 755 "target/release/${pkgname%-git}" -t "${pkgdir}/usr/bin"
+ install -Dm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname"
+}