summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoryo2019-05-16 08:51:10 +0200
committeryo2019-05-16 08:51:10 +0200
commit6bce0f79da2bcaaf18c54b3157b2badbe4bac530 (patch)
tree5d4ef8e3df7a12fe3b8d9d6881c512773bf44a79
downloadaur-6bce0f79da2bcaaf18c54b3157b2badbe4bac530.tar.gz
removing folder once archive built
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD30
3 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a082651aa2e9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = zipf
+ pkgdesc = CLI tool to directly zip several files/folders or an existing folder
+ pkgver = 1.0.2
+ pkgrel = 1
+ url = https://github.com/yoarch/zipf
+ arch = any
+ license = MIT
+ makedepends = python
+ makedepends = python-setuptools
+ depends = python>=3
+ source = https://files.pythonhosted.org/packages/source/z/zipfs/zipfs-1.0.2.tar.gz
+ sha256sums = e20f1e8480b534ddf36f531eb778fb8605c459ef74c05362d9998f96f79493d3
+
+pkgname = zipf
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..c6a9b954b0ed
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..781f4fbb13ce
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Yann Orieult <yo.managements@gmail.com>
+
+pkgname=zipf
+pkgver='1.0.2'
+pkgrel='1'
+pkgdesc='CLI tool to directly zip several files/folders or an existing folder'
+arch=('any')
+url='https://github.com/yoarch/zipf'
+license=('MIT')
+depends=('python>=3')
+makedepends=('python' 'python-setuptools')
+
+source=("https://files.pythonhosted.org/packages/source/z/zipfs/zipfs-1.0.2.tar.gz")
+sha256sums=('e20f1e8480b534ddf36f531eb778fb8605c459ef74c05362d9998f96f79493d3')
+#source#=("file:///$MHOME/dev/python/zipf/dist/zipfs-1.0.2.tar.gz")
+#sha256sums#=("SKIP")
+
+build() {
+ cd $srcdir/zipfs-${pkgver}
+ python setup.py build
+}
+
+package() {
+ cd $srcdir/zipfs-${pkgver}
+
+ python setup.py install --root="$pkgdir/" --optimize=1
+
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 README.md "$pkgdir/usr/lib/$pkgname/README.md"
+}