summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSeverin Glöckner2018-12-01 02:00:41 +0100
committerSeverin Glöckner2018-12-01 02:00:41 +0100
commitd687cb1e6d758a5d44f6c00f590cdb2af44d2c60 (patch)
tree0d8b16079f8eccbf803d7a5c9fef8c0115165107
downloadaur-d687cb1e6d758a5d44f6c00f590cdb2af44d2c60.tar.gz
old zipios library, required by some old programs
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD40
2 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0400d9d06456
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = zipios++
+ pkgdesc = Small C++ library for reading and writing zip files (old version)
+ pkgver = 0.1.5.9+cvs.2007.04.28
+ pkgrel = 10
+ url = http://zipios.sourceforge.net
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ makedepends = cppunit
+ depends = zlib
+ conflicts = zipios-git
+ source = orig::https://deb.debian.org/debian/pool/main/z/zipios++/zipios++_0.1.5.9+cvs.2007.04.28.orig.tar.gz
+ source = debian(compressed)::https://deb.debian.org/debian/pool/main/z/zipios++/zipios++_0.1.5.9+cvs.2007.04.28-10.debian.tar.xz
+ md5sums = cb321973d3ab5f39ee0df77ef0af7929
+ md5sums = ceff9b8060538f806571cd9cc489a71a
+
+pkgname = zipios++
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a2098331b60c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer Severin Glöckner <severin.gloeckner@stud.htwk-leipzig.de>
+
+# old version, use this only if an old program depends on zipios++
+pkgname=zipios++
+pkgver=0.1.5.9+cvs.2007.04.28 # debian's version number
+pkgrel=10
+pkgdesc="Small C++ library for reading and writing zip files (old version)"
+arch=('i686' 'x86_64')
+url="http://zipios.sourceforge.net"
+license=('LGPL')
+conflicts=('zipios-git')
+depends=('zlib')
+makedepends=('cppunit')
+source=("orig::https://deb.debian.org/debian/pool/main/z/zipios++/zipios++_0.1.5.9+cvs.2007.04.28.orig.tar.gz"
+ "debian(compressed)::https://deb.debian.org/debian/pool/main/z/zipios++/zipios++_0.1.5.9+cvs.2007.04.28-10.debian.tar.xz")
+
+md5sums=('cb321973d3ab5f39ee0df77ef0af7929'
+ 'ceff9b8060538f806571cd9cc489a71a')
+
+prepare() {
+ cd zipios++*
+ patch -p1 < ../debian/patches/no_logo.diff
+ patch -p1 < ../debian/patches/zipinputstreambuf.diff
+ patch -p1 < ../debian/patches/ptrdiff.diff
+ patch -p1 < ../debian/patches/gcc43_fix.diff
+ patch -p1 < ../debian/patches/amd64_fix.diff
+ patch -p1 < ../debian/patches/pkg-config.diff
+}
+
+build() {
+ cd zipios++*
+ ./autogen.sh
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd zipios++*
+ make DESTDIR=$pkgdir install
+}