summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortyls2020-05-08 18:07:28 -0500
committertyls2020-05-08 18:07:28 -0500
commit9284977c10a7aa51c63ae99d8a96d74f16882927 (patch)
tree766bf1abc531c5e98b6df552911e5aa9e1410c12
downloadaur-9284977c10a7aa51c63ae99d8a96d74f16882927.tar.gz
Initial commit: PKGBUILD
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD34
3 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..23c456193960
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = ziplib-git
+ pkgdesc = Petr Beneš C++11 library for working with Zip archives with ease.
+ pkgver = 0.1
+ pkgrel = 1
+ url = https://bitbucket.org/wbenny/ziplib/wiki/Home
+ arch = x86_64
+ license = custom
+ makedepends = make
+ makedepends = clang
+ makedepends = git
+ makedepends = rsync
+ options = !libtool
+ source = git+https://bitbucket.org/wbenny/ziplib.git
+ md5sums = SKIP
+
+pkgname = ziplib-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..108fd32cbe1e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg
+src
+ziplib
+*.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ef5f29e50604
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Tim Lewis <tyls at zeoliq dot com>
+pkgname=ziplib-git
+_pkgname=ziplib
+pkgver=0.1
+pkgrel=1
+pkgdesc="Petr Beneš C++11 library for working with Zip archives with ease."
+license=('custom')
+arch=('x86_64')
+url='https://bitbucket.org/wbenny/ziplib/wiki/Home'
+options=(!libtool)
+makedepends=(make clang git rsync)
+source=("git+https://bitbucket.org/wbenny/ziplib.git")
+md5sums=('SKIP')
+
+build() {
+ cd "$srcdir/$_pkgname"
+ make
+}
+
+package() {
+ cd "$srcdir/ziplib"
+
+ libdir="$pkgdir/usr/lib/"
+ includedir="$pkgdir/usr/include/$_pkgname"
+
+ mkdir -p $libdir
+ mkdir -p $includedir
+
+ cp Bin/libzip.so $libdir/lib$_pkgname.so
+ install -D -m644 Licence.txt "$pkgdir/usr/share/licenses/$_pkgname/LICENSE"
+
+ cd Source/ZipLib
+ find . -name '*.h' -exec rsync -rR {} $includedir \;
+}