summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Golatofski2020-01-06 20:40:15 +0100
committerFelix Golatofski2020-01-06 20:40:15 +0100
commit1901a2660be5ba4bd4ed2122ec0cba2f5f0ad26c (patch)
tree97f4910ba82a6e2fceccae1d8573f33d72ffa115
parent5f82d9d0f74e75ba4f60c74d000a8d4e8eabfd9c (diff)
downloadaur-1901a2660be5ba4bd4ed2122ec0cba2f5f0ad26c.tar.gz
Updated to 1.2.11
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD58
2 files changed, 43 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2a06bb348d76..049de0a5da19 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,20 @@
pkgbase = zlib-asm
pkgdesc = Compression library implementing the deflate compression method found in gzip and PKZIP
- pkgver = 1.2.8
+ pkgver = 1.2.11
pkgrel = 1
- url = http://www.zlib.net/
+ url = https://www.zlib.net/
arch = i686
arch = x86_64
license = custom
depends = glibc
- provides = zlib=1.2.8
+ provides = zlib=1.2.11
conflicts = zlib
- source = http://zlib.net/current/zlib-1.2.8.tar.gz
- md5sums = 44d667c142d7cda120332623eab69f40
+ options = staticlibs
+ source = https://zlib.net/zlib-1.2.11.tar.gz
+ source = https://zlib.net/zlib-1.2.11.tar.gz.asc
+ validpgpkeys = 5ED46A6721D365587791E2AA783FCD8E58BCAFBA
+ sha512sums = 73fd3fff4adeccd4894084c15ddac89890cd10ef105dd5e1835e1e9bbb6a49ff229713bd197d203edfa17c2727700fce65a2a235f07568212d820dca88b528ae
+ sha512sums = SKIP
pkgname = zlib-asm
diff --git a/PKGBUILD b/PKGBUILD
index f8aa2f43d87b..f242ee6959cd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,46 +1,56 @@
# Maintainer: Dave Reisner <dreisner@archlinux.org>
+# Maintainer: Felix Golatofski <contact@xdfr.de>
-pkgname=(zlib-asm)
-pkgver=1.2.8
+pkgname=zlib-asm
+pkgver=1.2.11
pkgrel=1
pkgdesc='Compression library implementing the deflate compression method found in gzip and PKZIP'
arch=('i686' 'x86_64')
license=('custom')
-url="http://www.zlib.net/"
-depends=('glibc')
+url="https://www.zlib.net/"
provides=("zlib=$pkgver")
conflicts=('zlib')
-source=("http://zlib.net/current/zlib-$pkgver.tar.gz")
-md5sums=('44d667c142d7cda120332623eab69f40')
+depends=('glibc')
+options=('staticlibs') # needed by binutils testsuite
+source=("https://zlib.net/zlib-$pkgver.tar.gz"{,.asc})
+sha512sums=('73fd3fff4adeccd4894084c15ddac89890cd10ef105dd5e1835e1e9bbb6a49ff229713bd197d203edfa17c2727700fce65a2a235f07568212d820dca88b528ae'
+ 'SKIP')
+validpgpkeys=('5ED46A6721D365587791E2AA783FCD8E58BCAFBA')
+
+prepare() {
+ cd ${srcdir}/zlib-$pkgver
+ grep -A 24 '^ Copyright' zlib.h > LICENSE
+}
build() {
- cd "zlib-$pkgver"
+ cd ${srcdir}/zlib-$pkgver
- # use ASM optimizations
- case $CARCH in
- x86_64)
- cp contrib/gcc_gvmat64/gvmat64.S ./match.S
- ;;
- i686)
- cp contrib/asm686/match.S ./match.S
- ;;
- esac
+ # use ASM optimizations
+ case $CARCH in
+ x86_64)
+ cp contrib/gcc_gvmat64/gvmat64.S ./match.S
+ ;;
+ i686)
+ cp contrib/asm686/match.S ./match.S
+ ;;
+ esac
- CFLAGS+=' -O3 -DASMV'
+ CFLAGS+=' -O3 -DASMV'
- ./configure --prefix=/usr
- make OBJA=match.o PIC_OBJA=match.lo
+ ./configure --prefix=/usr
+ make OBJA=match.o PIC_OBJA=match.lo
- sed '/\*\//q' zlib.h > LICENSE
+ sed '/\*\//q' zlib.h > LICENSE
}
check() {
- make -C zlib-$pkgver test
+ cd ${srcdir}/zlib-$pkgver
+ make test
}
package() {
- cd "zlib-$pkgver"
+ cd ${srcdir}/zlib-$pkgver
- make install "DESTDIR=$pkgdir"
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/zlib/LICENSE"
+ make install DESTDIR=$pkgdir
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/zlib/LICENSE"
}