summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDave Reisner2015-07-04 13:47:21 -0400
committerDave Reisner2015-07-04 13:47:21 -0400
commit5f82d9d0f74e75ba4f60c74d000a8d4e8eabfd9c (patch)
tree34051e33b95505b2a313f2ec3cd7de586f6bf259
downloadaur-5f82d9d0f74e75ba4f60c74d000a8d4e8eabfd9c.tar.gz
initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD46
2 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2a06bb348d76
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = zlib-asm
+ pkgdesc = Compression library implementing the deflate compression method found in gzip and PKZIP
+ pkgver = 1.2.8
+ pkgrel = 1
+ url = http://www.zlib.net/
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = glibc
+ provides = zlib=1.2.8
+ conflicts = zlib
+ source = http://zlib.net/current/zlib-1.2.8.tar.gz
+ md5sums = 44d667c142d7cda120332623eab69f40
+
+pkgname = zlib-asm
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f8aa2f43d87b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Dave Reisner <dreisner@archlinux.org>
+
+pkgname=(zlib-asm)
+pkgver=1.2.8
+pkgrel=1
+pkgdesc='Compression library implementing the deflate compression method found in gzip and PKZIP'
+arch=('i686' 'x86_64')
+license=('custom')
+url="http://www.zlib.net/"
+depends=('glibc')
+provides=("zlib=$pkgver")
+conflicts=('zlib')
+source=("http://zlib.net/current/zlib-$pkgver.tar.gz")
+md5sums=('44d667c142d7cda120332623eab69f40')
+
+build() {
+ cd "zlib-$pkgver"
+
+ # use ASM optimizations
+ case $CARCH in
+ x86_64)
+ cp contrib/gcc_gvmat64/gvmat64.S ./match.S
+ ;;
+ i686)
+ cp contrib/asm686/match.S ./match.S
+ ;;
+ esac
+
+ CFLAGS+=' -O3 -DASMV'
+
+ ./configure --prefix=/usr
+ make OBJA=match.o PIC_OBJA=match.lo
+
+ sed '/\*\//q' zlib.h > LICENSE
+}
+
+check() {
+ make -C zlib-$pkgver test
+}
+
+package() {
+ cd "zlib-$pkgver"
+
+ make install "DESTDIR=$pkgdir"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/zlib/LICENSE"
+}