summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12017-08-18 22:57:09 +0800
committerChocobo12017-08-18 23:05:18 +0800
commita955f6d9ceedc5da4a200521c3761c3c6ff1e69b (patch)
treeb54176288b6e1a88ca4c03cc8646d371c4516017
downloadaur-a955f6d9ceedc5da4a200521c3761c3c6ff1e69b.tar.gz
newpkg: zlib-git 1.2.11.r16.g3c46f5d-1
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD45
2 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8a282a4e4785
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = zlib-git
+ pkgdesc = A massively spiffy yet delicately unobtrusive compression library (git develop branch)
+ pkgver = 1.2.11.r16.g3c46f5d
+ pkgrel = 1
+ url = https://www.zlib.net/
+ arch = i686
+ arch = x86_64
+ license = ZLIB
+ makedepends = git
+ depends = glibc
+ provides = zlib
+ conflicts = zlib
+ options = staticlibs
+ source = git+https://github.com/madler/zlib.git#branch=develop
+ sha256sums = SKIP
+
+pkgname = zlib-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9747c2a19090
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=zlib-git
+pkgver=1.2.11.r16.g3c46f5d
+pkgrel=1
+pkgdesc="A massively spiffy yet delicately unobtrusive compression library (git develop branch)"
+arch=('i686' 'x86_64')
+url="https://www.zlib.net/"
+license=('ZLIB')
+depends=('glibc')
+makedepends=('git')
+provides=('zlib')
+conflicts=('zlib')
+options=('staticlibs')
+source=("git+https://github.com/madler/zlib.git#branch=develop")
+sha256sums=('SKIP')
+
+
+pkgver() {
+ cd "zlib"
+
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "zlib"
+
+ ./configure --prefix="/usr"
+ make
+}
+
+check() {
+ cd "zlib"
+
+ make test
+}
+
+package() {
+ cd "zlib"
+
+ make DESTDIR="$pkgdir" install
+
+ sed -n '/Copyright (C) 1995-/,/madler@alumni.caltech.edu/p' "zlib.h" > "_LICENSE"
+ install -Dm644 "_LICENSE" "$pkgdir/usr/share/licenses/zlib/LICENSE"
+}