summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRadu Potop2016-10-01 16:05:12 +0300
committerRadu Potop2016-10-01 16:05:12 +0300
commit85e0f84deaf0f132f7d856de48230674105f1a88 (patch)
tree93ceb3269850369f0e70c844c622c643ec098b7d
downloadaur-85e0f84deaf0f132f7d856de48230674105f1a88.tar.gz
Initial commit of zlib-ng
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD31
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ad53adaba866
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = zlib-ng-git
+ pkgdesc = zlib for the "next generation" systems. Drop-In replacement with some serious optimizations.
+ pkgver = 1.2.8
+ pkgrel = 1
+ url = https://github.com/Dead2/zlib-ng
+ arch = i686
+ arch = x86_64
+ license = zlib
+ depends = glibc
+ conflicts = zlib
+ source = git://github.com/Dead2/zlib-ng.git
+ md5sums = SKIP
+
+pkgname = zlib-ng-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..61b43f962d1a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Contributor: Radu Potop <radu@wooptoo.com>
+
+pkgname=zlib-ng-git
+pkgver=1.2.8
+pkgrel=1
+pkgdesc='zlib for the "next generation" systems. Drop-In replacement with some serious optimizations.'
+arch=('i686' 'x86_64')
+license=('zlib')
+url="https://github.com/Dead2/zlib-ng"
+depends=('glibc')
+source=("git://github.com/Dead2/zlib-ng.git")
+conflicts=('zlib')
+md5sums=('SKIP')
+_gitname='zlib-ng'
+
+build() {
+ cd ${srcdir}/${_gitname}
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd ${srcdir}/${_gitname}
+ make install DESTDIR=${pkgdir}
+
+ install -D libz.so ${pkgdir}/usr/lib/libz.so
+ install -D libz.so.1 ${pkgdir}/usr/lib/libz.so.1
+ install -D libz.so.${pkgver}.zlib-ng ${pkgdir}/usr/lib/libz.so.${pkgver}
+
+ install -D -m644 LICENSE.md ${pkgdir}/usr/share/licenses/zlib/LICENSE
+}