summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTechcable2021-03-30 21:09:26 -0700
committerTechcable2021-03-30 21:09:26 -0700
commitdab68176bf5d9f75b21917a600a3af8e0393dc26 (patch)
treecea9a28292cb2e7595da5271444fe3be174ad138
parentac0f0cfbe90fe70ef7b1682dfe10d60ea0aa37e4 (diff)
downloadaur-dab68176bf5d9f75b21917a600a3af8e0393dc26.tar.gz
Technically, our python script is a "source"
Unfortunately this bumps the pkgrel to 0.1.0-2 :( Fortunately rebuilding should be fast (since the tar already exists). This should fix cafce25's problem building with aurutils. Probably some sort of weird chroot problem.... To quote: > I tried to build it with aurutils today but it complains that the update_config.py cannot be found. > This is probably due to it being referenced relatively to the src directory. But that might not be the case. > I tried to replace the '../update_config.py' with '${startdir}/update_config.py' and that seemed to have worked although i don't know aurutils very well.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
2 files changed, 10 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2016c47f0063..4096163da5cb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = zls-bin
pkgdesc = Zig Language Server, or zls, is a language server for Zig. Pre-compiled official binary.
pkgver = 0.1.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/zigtools/zls
arch = x86_64
license = MIT
@@ -13,6 +13,8 @@ pkgbase = zls-bin
replaces = zls
replaces = zls-git
backup = usr/bin/zls.json
+ source = update_config.py
+ sha256sums = f55e83f8510c50d55d7f37fa6dfa4d0f9a99061099829b350fa58892bc828a57
source_x86_64 = https://github.com/zigtools/zls/releases/download/0.1.0/x86_64-linux.tar.xz
sha256sums_x86_64 = 1318a785e6982ef86d1d0242403b20cec34ce209c64eee339512f8267e9a5ccb
diff --git a/PKGBUILD b/PKGBUILD
index a860d8aed237..c4379311a98e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Nicholas Schlabach <Techcable at techcable dot net>
pkgname=zls-bin
pkgver="0.1.0"
-pkgrel=1
+pkgrel=2
pkgdesc="Zig Language Server, or zls, is a language server for Zig. Pre-compiled official binary."
arch=('x86_64')
url="https://github.com/zigtools/zls"
@@ -9,7 +9,8 @@ license=('MIT')
depends=('zig')
# Used to update the `zls.json` file with the path to our build runner.
# See: https://github.com/zigtools/zls/blob/master/README.md#configuration-options
-# I could use `jq` but I think python is more prevalent ;)
+# I could use `jq` but I think python is more prevalent (although jq seems
+# surprisingly common, just look at the reverse dependencies for `jq-git`)
makedepends=('python>=3.6')
provides=('zls')
conflicts=('zls' 'zls-git')
@@ -22,9 +23,12 @@ replaces=('zls' 'zls-git')
backup=('usr/bin/zls.json')
source_x86_64=("https://github.com/zigtools/zls/releases/download/${pkgver}/x86_64-linux.tar.xz")
sha256sums_x86_64=("1318a785e6982ef86d1d0242403b20cec34ce209c64eee339512f8267e9a5ccb")
+# Technically, our python script is a "source"
+source=("update_config.py")
+sha256sums=("f55e83f8510c50d55d7f37fa6dfa4d0f9a99061099829b350fa58892bc828a57")
prepare() {
- python3 ../update_config.py $CARCH-linux/zls.json || exit 1
+ python3 "${srcdir}/update_config.py" "${srcdir}/$CARCH-linux/zls.json"
}
package() {