summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2021-02-23 01:10:03 +0000
committerDaniel Bermond2021-02-23 01:10:03 +0000
commit14e6eecaae29bb7545fd743e6b43c6516dcc51fd (patch)
treedf4a05321e2639a7aed44f45642b150f561ae596
parent0f1c5c9c52dacb06936849722ae46a4b0dc050e8 (diff)
downloadaur-14e6eecaae29bb7545fd743e6b43c6516dcc51fd.tar.gz
package(): install files according to upstream
executable zluda_with and library libzluda_redirect seems to be for windows only[1], although they also build for linux. Upstream GitHub actions[2] and distributed linux binaries[3] includes only libcuda on the package. Only the packaged windows binaries[4] includes zluda_with and library libzluda_redirect. References ---------- [1] https://github.com/vosen/ZLUDA/blob/v2/.github/workflows/rust.yml#L49-L55 [2] https://github.com/vosen/ZLUDA/blob/v2/.github/workflows/rust.yml#L29-L38 [3] https://github.com/vosen/ZLUDA/releases/download/v2/zluda-2-linux.zip [4] https://github.com/vosen/ZLUDA/releases/download/v2/zluda-2-windows.zip
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD9
2 files changed, 4 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e29a207d8ace..474d80fc51fe 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = zluda
pkgdesc = A drop-in replacement for CUDA on Intel GPUs
pkgver = 2
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/vosen/ZLUDA/
arch = x86_64
license = Apache
diff --git a/PKGBUILD b/PKGBUILD
index 24666ff518b3..1cec5dd07953 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=zluda
pkgver=2
-pkgrel=1
+pkgrel=2
pkgdesc='A drop-in replacement for CUDA on Intel GPUs'
arch=('x86_64')
url='https://github.com/vosen/ZLUDA/'
@@ -34,10 +34,7 @@ check() {
}
package() {
- install -D -m755 ZLUDA/target/release/zluda_with -t "${pkgdir}/usr/bin"
- install -D -m644 ZLUDA/target/release/libnvcuda.so -t "${pkgdir}/usr/lib"
- install -D -m644 ZLUDA/target/release/libzluda_redirect.so -t "${pkgdir}/usr/lib"
+ install -D -m644 ZLUDA/target/release/libnvcuda.so "${pkgdir}/usr/lib/libcuda.so.1"
install -D -m644 ZLUDA/LICENSE-MIT -t "${pkgdir}/usr/share/licenses/${pkgname}"
- ln -s libnvcuda.so "${pkgdir}/usr/lib/libcuda.so"
- ln -s libnvcuda.so "${pkgdir}/usr/lib/libcuda.so.1"
+ ln -s libcuda.so.1 "${pkgdir}/usr/lib/libcuda.so"
}