summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Limiero2024-09-20 17:13:26 -0400
committerMichael Limiero2024-09-20 17:13:26 -0400
commit3c72fc969c73ff51bae1b7ec73e312e0cd15944c (patch)
tree22d5d2cdef44b788e64319075b649f47868e49b3
downloadaur-3c72fc969c73ff51bae1b7ec73e312e0cd15944c.tar.gz
create zmkbatx package
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD52
-rw-r--r--zmkbatx-1.0.1.patch21
3 files changed, 89 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c658e6ac6ab9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = zmkbatx
+ pkgdesc = Tool for peripheral battery monitoring for ZMK split keyboards over BLE
+ pkgver = 1.0.1
+ pkgrel = 1
+ arch = x86_64
+ license = MIT
+ depends = simplebluez
+ depends = qt6-base
+ depends = qt6-connectivity
+ depends = dbus
+ source = https://github.com/mh4x0f/zmkBATx/archive/refs/tags/v1.0.1.tar.gz
+ source = zmkbatx-1.0.1.patch
+ sha256sums = 33a2f2cbb63cae1159240bf57e8a30666b432fc831d0dcc439f71022ce658a01
+ sha256sums = SKIP
+
+pkgname = zmkbatx
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..793ddec6be3e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Michael Limiero <mike5713 at gmail dot com>
+pkgname=zmkbatx
+pkgver=1.0.1
+pkgrel=1
+epoch=
+pkgdesc="Tool for peripheral battery monitoring for ZMK split keyboards over BLE"
+arch=("x86_64")
+url=""
+license=('MIT')
+groups=()
+depends=("simplebluez" "qt6-base" "qt6-connectivity" "dbus")
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("https://github.com/mh4x0f/zmkBATx/archive/refs/tags/v${pkgver}.tar.gz"
+ "zmkbatx-1.0.1.patch")
+noextract=()
+sha256sums=('33a2f2cbb63cae1159240bf57e8a30666b432fc831d0dcc439f71022ce658a01' 'SKIP')
+validpgpkeys=()
+
+prepare() {
+ cd "zmkBATx-$pkgver"
+ patch -p1 -i "$srcdir/$pkgname-$pkgver.patch"
+}
+
+build() {
+ cd "zmkBATx-$pkgver"
+ qmake6 zmkBATx.pro -spec linux-g++ CONFIG+=qtquickcompiler INCPATH+=' /usr/lib64/dbus-1.0/include' LIBS+='-lsimpledbus ' PREFIX=/usr
+ make
+}
+
+# check() {
+# cd "zmkBATx-$pkgver"
+# make -k check
+# }
+
+package() {
+ cd "zmkBATx-$pkgver"
+ make INSTALL_ROOT="$pkgdir/" install
+}
diff --git a/zmkbatx-1.0.1.patch b/zmkbatx-1.0.1.patch
new file mode 100644
index 000000000000..aa0300d74ef0
--- /dev/null
+++ b/zmkbatx-1.0.1.patch
@@ -0,0 +1,21 @@
+diff --git a/zmkBATx.pro b/zmkBATx.pro
+index 3b00a3c..fc64e6d 100644
+--- a/zmkBATx.pro
++++ b/zmkBATx.pro
+@@ -35,7 +35,7 @@ OTHER_FILES += README.md \
+ deploy_dep.sh \
+ .gitignore
+
+-LIBS += -L$$PWD/src/thirdparty/ -lsimplebluez
++LIBS += -L$$PWD/src/thirdparty/ -lsimplebluez -lsimpledbus
+
+ INCLUDEPATH += $$PWD/src/thirdparty
+ DEPENDPATH += $$PWD/src/thirdparty
+@@ -45,6 +45,7 @@ INCLUDEPATH += /usr/include/dbus-1.0
+
+ # Inclui o diretório para o mecanismo de sistema de mensagem D-Bus
+ INCLUDEPATH += /usr/lib/x86_64-linux-gnu/dbus-1.0/include
++INCLUDEPATH += /usr/lib64/dbus-1.0/include
+
+ # Link com a biblioteca D-Bus
+ LIBS += -ldbus-1