summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcorey drew bruce2024-03-20 01:01:55 +1000
committercorey drew bruce2024-03-20 01:01:55 +1000
commitdca18af04e0f49ab11bda27f0455098be7b75190 (patch)
tree031b2031c7de932ac6333427981e5c55434ed794
downloadaur-dca18af04e0f49ab11bda27f0455098be7b75190.tar.gz
Zmusic 1.1.12-1
-rw-r--r--.SRCINFO25
-rwxr-xr-xPKGBUILD33
2 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ec4c0c0de233
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = zmusic-bin
+ pkgdesc = GZDoom's music system as a standalone library
+ pkgver = 1.1.12
+ pkgrel = 1
+ arch = x86_64
+ arch = aarch64
+ license = BSD
+ license = GPL3
+ license = LGPL2.1
+ license = LGPL3
+ license = custom:dumb
+ makedepends = unzip
+ depends = alsa-lib
+ depends = libsndfile
+ depends = mpg123
+ depends = zlib
+ optdepends = soundfont-fluid: default soundfont for FluidSynth
+ conflicts = zmusic
+ conflicts = zmusic-git
+ source_x86_64 = https://gitlab.com/zmusic-bin/binaries/1.1.12/-/raw/main/zmusic-linux-x64.tar.xz
+ sha256sums_x86_64 = SKIP
+ source_aarch64 = https://gitlab.com/zmusic-bin/binaries/1.1.12/-/raw/main/zmusic-linux-arm64.tar.xz
+ sha256sums_aarch64 = SKIP
+
+pkgname = zmusic-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..6f36faa66a76
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+pkgname=zmusic-bin
+pkgver=1.1.12
+pkgrel=1
+pkgdesc="GZDoom's music system as a standalone library"
+arch=('x86_64' 'aarch64')
+url=""
+license=('BSD' 'GPL3' 'LGPL2.1' 'LGPL3' 'custom:dumb')
+depends=('alsa-lib' 'libsndfile' 'mpg123' 'zlib')
+conflicts=("zmusic" "zmusic-git")
+optdepends=('soundfont-fluid: default soundfont for FluidSynth')
+makedepends=('unzip')
+_pkgrel_x86_64=1
+_pkgrel_aarch64=1
+sha256sums_x86_64=('SKIP')
+sha256sums_aarch64=('SKIP')
+#_pkgrel_i386=1
+#_pkgrel_i686=1
+#sha256sums_i386=('SKIP')
+#sha256sums_i686=('SKIP')
+source_x86_64=("https://gitlab.com/zmusic-bin/binaries/$pkgver/-/raw/main/zmusic-linux-x64.tar.xz")
+source_aarch64=("https://gitlab.com/zmusic-bin/binaries/$pkgver/-/raw/main/zmusic-linux-arm64.tar.xz")
+#source_i386=("zmusic-linux-i386.tar.xz")
+#source_i686=("zmusic-linux-i386.tar.xz")
+
+package() {
+ install -dm755 "$pkgdir/usr/lib"
+ install -dm755 "$pkgdir/usr/share"
+ install -dm755 "$pkgdir/usr/include"
+
+ #Removing uneeded .files
+ rm -rf $srcdir/zmusic/.*
+ cp -r "$srcdir/zmusic/." "$pkgdir"
+}