summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSTREBLO2016-05-30 18:10:49 -0700
committerSTREBLO2016-05-30 18:10:49 -0700
commit526d04395718a53d00d3e1ac7667785839bf4878 (patch)
treed8d4a8c860a6fcba20a1806fb087d8999bdbb587
parentdbe1ab16a9e08260244b515ee7fa62bf71407ba9 (diff)
downloadaur-526d04395718a53d00d3e1ac7667785839bf4878.tar.gz
Fixed systemd unit referencing incorrect path /usr/local/bin
-rw-r--r--PKGBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 19a2ea4e492b..6c55b6e48d9f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: John Ramsden <streblo@ramsdenj.ca>
pkgname=znapzend
pkgver=0.15.7
-pkgrel=1
+pkgrel=2
pkgdesc="ZnapZend is a ZFS centric backup tool. It relies on snapshot, send and receive todo its work. It has the built-in ability to manage both local snapshots as well as remote copies by thining them out as time progresses."
arch=('any')
url="http://www.znapzend.org/"
@@ -11,6 +11,11 @@ source=("https://github.com/oetiker/${pkgname}/releases/download/v${pkgver}/${pk
noextract=()
md5sums=('c464e0799212f025c31859737c3ce4bc')
+prepare() {
+ cd "${pkgname}-${pkgver}"
+ sed -i 's:ExecStart=/usr/local/bin/znapzend:ExecStart=/usr/bin/znapzend:' "init/znapzend.service"
+}
+
build() {
cd "${pkgname}-${pkgver}"
./configure --prefix="/opt/${pkgname}-${pkgver}"
@@ -24,6 +29,6 @@ package() {
ln -s "/opt/${pkgname}-${pkgver}/bin/znapzend" "${pkgdir}/usr/bin/znapzend"
ln -s "/opt/${pkgname}-${pkgver}/bin/znapzendzetup" "${pkgdir}/usr/bin/znapzendzetup"
ln -s "/opt/${pkgname}-${pkgver}/bin/znapzendztatz" "${pkgdir}/usr/bin/znapzendztatz"
- cp "init/znapzend.service" "${pkgdir}/etc/systemd/system/"
- cp "man/znapzend.1" "man/znapzendzetup.1" "man/znapzendztatz.1" "${pkgdir}/usr/share/man/man1"
+ install -m 644 "init/znapzend.service" "${pkgdir}/etc/systemd/system/znapzend.service"
+ install -m 644 "man/znapzend.1" "man/znapzendzetup.1" "man/znapzendztatz.1" "${pkgdir}/usr/share/man/man1"
}