summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn Ramsden2018-06-21 14:59:45 -0700
committerJohn Ramsden2018-06-21 15:01:16 -0700
commite68f6d0878345afbca3872194ae60f0b98c778a0 (patch)
tree448dde80fb01e9e6e2b2ef12cf09aec1b6f295dd
parent58bfd2e113046a65c3887e865b91f1fb8ca4bf7a (diff)
downloadaur-e68f6d0878345afbca3872194ae60f0b98c778a0.tar.gz
Update to v0.19.0
Also add mbuffer optdepend
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD18
2 files changed, 13 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ac123d40c8db..f8da08397f70 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,15 @@
pkgbase = znapzend
pkgdesc = ZnapZend is a ZFS centric backup tool. It relies on snapshot, send and receive todo its work. It has the built-in ability to manage both local snapshots as well as remote copies by thining them out as time progresses.
- pkgver = 0.18.0
+ pkgver = 0.19.0
pkgrel = 1
url = http://www.znapzend.org/
arch = any
license = GPL
depends = perl
depends = zfs
- source = https://github.com/oetiker/znapzend/releases/download/v0.18.0/znapzend-0.18.0.tar.gz
- md5sums = b77f02a76adcd2fa246660485df30a87
+ optdepends = mbuffer: stream buffering
+ source = https://github.com/oetiker/znapzend/releases/download/v0.19.0/znapzend-0.19.0.tar.gz
+ md5sums = 3e2aed2cf918dbba0931da3058578df7
pkgname = znapzend
diff --git a/PKGBUILD b/PKGBUILD
index ae6690d69892..5a64245a197a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,25 @@
# Maintainer: John Ramsden <johnramsden [at] riseup [dot] net>
pkgname=znapzend
-pkgver=0.18.0
+pkgver=0.19.0
pkgrel=1
pkgdesc="ZnapZend is a ZFS centric backup tool. It relies on snapshot, send and receive todo its work. It has the built-in ability to manage both local snapshots as well as remote copies by thining them out as time progresses."
arch=('any')
url="http://www.znapzend.org/"
license=('GPL')
depends=('perl' 'zfs')
+optdepends=('mbuffer: stream buffering')
source=("https://github.com/oetiker/${pkgname}/releases/download/v${pkgver}/${pkgname}-${pkgver}.tar.gz")
-noextract=()
-md5sums=('b77f02a76adcd2fa246660485df30a87')
+md5sums=('3e2aed2cf918dbba0931da3058578df7')
prepare() {
cd "${pkgname}-${pkgver}"
- sed -i 's:/usr/local/bin:/usr/bin:g' "init/znapzend.service"
+ sed -i 's:@BINDIR@:/usr/bin:' "init/znapzend.service.in"
}
build() {
cd "${pkgname}-${pkgver}"
- ./configure --prefix="/opt/${pkgname}-${pkgver}"
+ ./configure --prefix="/opt/${pkgname}"
make
}
@@ -27,9 +27,9 @@ package() {
cd "${pkgname}-${pkgver}"
make DESTDIR="${pkgdir}" install
mkdir -p "${pkgdir}/usr/bin" "${pkgdir}/usr/lib/systemd/system" "${pkgdir}/usr/share/man/man1"
- ln -s "/opt/${pkgname}-${pkgver}/bin/znapzend" "${pkgdir}/usr/bin/znapzend"
- ln -s "/opt/${pkgname}-${pkgver}/bin/znapzendzetup" "${pkgdir}/usr/bin/znapzendzetup"
- ln -s "/opt/${pkgname}-${pkgver}/bin/znapzendztatz" "${pkgdir}/usr/bin/znapzendztatz"
- install -m 644 "init/znapzend.service" "${pkgdir}/usr/lib/systemd/system//znapzend.service"
+ ln -s "/opt/${pkgname}/bin/znapzend" "${pkgdir}/usr/bin/znapzend"
+ ln -s "/opt/${pkgname}/bin/znapzendzetup" "${pkgdir}/usr/bin/znapzendzetup"
+ ln -s "/opt/${pkgname}/bin/znapzendztatz" "${pkgdir}/usr/bin/znapzendztatz"
+ install -m 644 "init/znapzend.service" "${pkgdir}/usr/lib/systemd/system/znapzend.service"
install -m 644 "man/znapzend.1" "man/znapzendzetup.1" "man/znapzendztatz.1" "${pkgdir}/usr/share/man/man1"
}