summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOleh Prypin2015-11-20 00:03:44 +0200
committerOleh Prypin2015-11-20 00:03:44 +0200
commiteef6cc3514bf5b7ee340b834db3d209d6817e906 (patch)
tree4de5532859ce726db236f31cbda41b4d35cb2836
downloadaur-eef6cc3514bf5b7ee340b834db3d209d6817e906.tar.gz
Initial import
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD26
3 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..87b13bb68d70
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = znc-chanfilter-git
+ pkgdesc = ZNC channel filter module for identified clients
+ pkgver = r62.cdfd196
+ pkgrel = 1
+ url = http://wiki.znc.in/Chanfilter
+ arch = i686
+ arch = x86_64
+ license = Apache
+ depends = znc
+ source = git+https://github.com/jpnurmi/znc-chanfilter.git
+ sha256sums = SKIP
+
+pkgname = znc-chanfilter-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..fb476c40885a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+*
+!.gitignore
+!PKGBUILD
+!*.install
+!*.sysusers
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..935bf1a30222
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Oleh Prypin <oleh@pryp.in>
+pkgname=znc-chanfilter-git
+pkgver=r62.cdfd196
+pkgrel=1
+pkgdesc="ZNC channel filter module for identified clients"
+arch=('i686' 'x86_64')
+url="http://wiki.znc.in/Chanfilter"
+license=('Apache')
+depends=('znc')
+source=("git+https://github.com/jpnurmi/znc-chanfilter.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd znc-chanfilter
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd znc-chanfilter
+ znc-buildmod chanfilter.cpp
+}
+
+package() {
+ cd znc-chanfilter
+ install -Dm755 chanfilter.so "$pkgdir/usr/lib/znc/chanfilter.so"
+}