summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJosef Vybíhal2022-03-29 21:56:51 +0200
committerJosef Vybíhal2022-03-29 21:56:51 +0200
commitb5a3e10aef68b8278873e58f649bb9dc69dd24ef (patch)
tree3f19b5cd313bc36475aee5221107f18ae256c636
parent8dfe9123332644b9476451b93e9cd32328cc9d5c (diff)
downloadaur-znc-fish.tar.gz
Replaced source.
The previous source had weird quirks, not working properly. This one is recommended by znc: https://wiki.znc.in/Fish For 1.6 (and/or OpenSSL >= 1.1) try this [one](https://gist.github.com/v4lli/ee4edd99128e7cb518ebad548cab7a41). It works for me, tested against FiSHLiM in Xchat, EBC.
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD17
2 files changed, 8 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a976e230d5ae..0420bbca0637 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = znc-fish
pkgdesc = FiSH Module for ZNC
- pkgver = r21.dfc4408
- pkgrel = 1
+ pkgver = 1.2018
+ pkgrel = 2
url = https://github.com/qnorsten/znc-fish
arch = x86_64
license = GPL
makedepends = cmake
depends = znc
provides = znc-fish
- source = git+https://github.com/qnorsten/znc-fish.git
- b2sums = SKIP
+ source = https://gist.githubusercontent.com/v4lli/ee4edd99128e7cb518ebad548cab7a41/raw/c2a3c05714d8fbab8bdbcb4a2a52c7099a7efbbf/fish.cpp
+ b2sums = 6982570d1083af973b45ce5a80313bb5634557e8b42bf2cbbe88af10bbb1fe58b39b59860a2d291519e3561d8c4679a205561ad6c6d40e9295aaa35cf636fecc
pkgname = znc-fish
diff --git a/PKGBUILD b/PKGBUILD
index 09745dda1a80..0a53945724a0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=znc-fish
-pkgver=r21.dfc4408
-pkgrel=1
+pkgver=1.2018
+pkgrel=2
pkgdesc='FiSH Module for ZNC'
arch=('x86_64')
url='https://github.com/qnorsten/znc-fish'
@@ -8,22 +8,13 @@ license=('GPL')
depends=('znc')
makedepends=('cmake')
provides=('znc-fish')
-#conflicts=('')
-source=('git+https://github.com/qnorsten/znc-fish.git')
-b2sums=('SKIP')
-_gitname='znc-fish'
-
-pkgver() {
- cd "$_gitname"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
-}
+source=('https://gist.githubusercontent.com/v4lli/ee4edd99128e7cb518ebad548cab7a41/raw/c2a3c05714d8fbab8bdbcb4a2a52c7099a7efbbf/fish.cpp')
+b2sums=('6982570d1083af973b45ce5a80313bb5634557e8b42bf2cbbe88af10bbb1fe58b39b59860a2d291519e3561d8c4679a205561ad6c6d40e9295aaa35cf636fecc')
build() {
- cd "$_gitname"
znc-buildmod fish.cpp
}
package() {
- cd "$_gitname"
install -Dm755 fish.so "${pkgdir}/usr/lib/znc/fish.so"
}