summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUffe Jakobsen2021-09-08 12:40:58 +0200
committerUffe Jakobsen2021-09-08 12:40:58 +0200
commitaa2f2a77df01e38117f9d60e42e202fcf1c1078b (patch)
treea02bd852af6524bd72d4cb2e48fcce5e8e6c07c6
parent8092d827c6f8fddacd5ceb0f009b1bb3b274d68e (diff)
downloadaur-aa2f2a77df01e38117f9d60e42e202fcf1c1078b.tar.gz
Update to znotes v0.4.6
-rw-r--r--.AURINFO13
-rw-r--r--.SRCINFO9
-rw-r--r--[-rwxr-xr-x]PKGBUILD34
3 files changed, 27 insertions, 29 deletions
diff --git a/.AURINFO b/.AURINFO
deleted file mode 100644
index 6d051d6f04b7..000000000000
--- a/.AURINFO
+++ /dev/null
@@ -1,13 +0,0 @@
-pkgbase = znotes
- pkgdesc = Lightweight crossplatform application for notes managment with simple interface
- pkgver = 0.4.5
- pkgrel = 5
- url = http://znotes.sourceforge.net
- arch = i686
- arch = x86_64
- license = GPL
- depends = qt4
- source = https://github.com/proton/zNotes/archive/master.zip
-
-pkgname = znotes
-
diff --git a/.SRCINFO b/.SRCINFO
index 9fd8d1960600..e5b30d8059e7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,13 @@
pkgbase = znotes
pkgdesc = Lightweight crossplatform application for notes managment with simple interface
- pkgver = 0.4.5
- pkgrel = 7
+ pkgver = 0.4.6
+ pkgrel = 1
url = http://znotes.sourceforge.net
arch = i686
arch = x86_64
license = GPL
depends = qt5-tools
- source = https://github.com/proton/zNotes/archive/master.zip
- md5sums = 9604bc0f00aa169c6caac8f2ccad98ab
+ source = https://github.com/proton/zNotes/archive/refs/tags/0.4.6.tar.gz
+ md5sums = dd727c3888d9e618e1d29acacae723e7
pkgname = znotes
-
diff --git a/PKGBUILD b/PKGBUILD
index 374663324409..87da2ad82715 100755..100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,39 @@
-# Maintainer: Alois Nespor <info@aloisnespor.info>
+# Maintainer: Uffe Jakobsen <>
+# Contributor: Alois Nespor <info@aloisnespor.info>
# Contributor: Kosava <kosava@archlinux.us>
+_pkgname=zNotes
+
pkgname=znotes
-pkgver=0.4.5
-pkgrel=7
+pkgver=0.4.6
+pkgrel=1
pkgdesc="Lightweight crossplatform application for notes managment with simple interface"
arch=('i686' 'x86_64')
url="http://znotes.sourceforge.net"
license=('GPL')
depends=('qt5-tools')
-source=(https://github.com/proton/zNotes/archive/master.zip)
-md5sums=('SKIP')
+source=(https://github.com/proton/zNotes/archive/refs/tags/${pkgver}.tar.gz)
+#md5sums=('SKIP')
+md5sums=('dd727c3888d9e618e1d29acacae723e7')
+#
+#
+#
-build() {
- cd $srcdir/zNotes-master
+build()
+{
+ cd "${srcdir}/${_pkgname}-${pkgver}"
lrelease-qt5 znotes.pro
qmake-qt5 QMAKE_CFLAGS_RELEASE="$CPPFLAGS $CFLAGS" QMAKE_CXXFLAGS_RELEASE="$CPPFLAGS $CXXFLAGS" QMAKE_LFLAGS_RELEASE="$LDFLAGS" PREFIX=/usr
make
}
-package() {
- cd $srcdir/zNotes-master
- make INSTALL_ROOT=$pkgdir install
+package()
+{
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ make INSTALL_ROOT=${pkgdir} install
}
-md5sums=('9604bc0f00aa169c6caac8f2ccad98ab')
+
+#
+# EOF
+#