summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlois Nešpor2015-07-01 23:52:23 +0200
committerAlois Nešpor2015-07-01 23:52:23 +0200
commitbbc333d4dff37bcfd57bcd37d72ae0d96294945c (patch)
tree7a145ad6cf295655d6bae5ada477d85463818221
downloadaur-bbc333d4dff37bcfd57bcd37d72ae0d96294945c.tar.gz
Initial import
-rw-r--r--.AURINFO13
-rw-r--r--.SRCINFO14
-rwxr-xr-xPKGBUILD26
3 files changed, 53 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..6d051d6f04b7
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,13 @@
+pkgbase = znotes
+ pkgdesc = Lightweight crossplatform application for notes managment with simple interface
+ pkgver = 0.4.5
+ pkgrel = 5
+ url = http://znotes.sourceforge.net
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = qt4
+ source = https://github.com/proton/zNotes/archive/master.zip
+
+pkgname = znotes
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fb8661e69074
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = znotes
+ pkgdesc = Lightweight crossplatform application for notes managment with simple interface
+ pkgver = 0.4.5
+ pkgrel = 5
+ url = http://znotes.sourceforge.net
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = qt4
+ source = https://github.com/proton/zNotes/archive/master.zip
+ md5sums = SKIP
+
+pkgname = znotes
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..8a128549f496
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Alois Nespor <info@aloisnespor.info>
+# Contributor: Kosava <kosava@archlinux.us>
+
+pkgname=znotes
+pkgver=0.4.5
+pkgrel=5
+pkgdesc="Lightweight crossplatform application for notes managment with simple interface"
+arch=('i686' 'x86_64')
+url="http://znotes.sourceforge.net"
+license=('GPL')
+depends=('qt4')
+source=(https://github.com/proton/zNotes/archive/master.zip)
+md5sums=('SKIP')
+
+build() {
+ cd $srcdir/zNotes-master
+ echo "QMAKE_CXXFLAGS_RELEASE = $CFLAGS" >> znotes.pro
+ echo "QMAKE_CFLAGS_RELEASE = $CXXFLAGS" >> znotes.pro
+ qmake-qt4 PREFIX=/usr
+ make
+}
+
+package() {
+ cd $srcdir/zNotes-master
+ make INSTALL_ROOT=$pkgdir install
+}