summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJiachen YANG2020-12-08 15:52:37 +0900
committerJiachen YANG2020-12-08 15:52:37 +0900
commite01631d537422fe0f484a2a6abaa9b9daaed3607 (patch)
tree5eef19002e8b5bfee143bf0d1cf99700ee32e080
parentf6420d0c57e481ae51af67bf3848617473402d42 (diff)
downloadaur-e01631d537422fe0f484a2a6abaa9b9daaed3607.tar.gz
zograscope-git: update to build with srcml 1.0.0
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD21
2 files changed, 22 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0584b4817320..f2f893c9647c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = zograscope-git
pkgdesc = syntax-aware diff that also provides a number of additional tools (zs-diff, zs-find, zs-gdiff, zs-hi, zs-stats)
- pkgver = r932.5a0a075
+ pkgver = r1063.b5434cb
pkgrel = 1
url = https://github.com/xaizek/zograscope
arch = x86_64
@@ -8,14 +8,19 @@ pkgbase = zograscope-git
makedepends = git
makedepends = boost
makedepends = srcml
+ makedepends = bison
depends = qt5-base
depends = libgit2
depends = boost-libs
+ depends = ncurses
optdepends = srcml: srcML related diff features
provides = zograscope
conflicts = zograscope
- source = zograscope::git+https://github.com/xaizek/zograscope.git#commit=5a0a0754478e7ae5bd76509d082821202bb5ddf0
+ source = zograscope::git+https://github.com/xaizek/zograscope.git
+ source = cursed::https://code.reversed.top/user/xaizek/libcursed
+ source = vle::https://code.reversed.top/user/xaizek/libvle
md5sums = SKIP
+ md5sums = 896020e55eddd4a60c6a2f049b69428d
+ md5sums = 76209f61ab1f0dbee12c68b238cf0d1d
pkgname = zograscope-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 55aa5d3ae9cc..cbb82ee34474 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,23 @@
# Maintainer: Jiachen YANG <farseerfc@gmail.com>
_pkgname=zograscope
-_commit=5a0a0754478e7ae5bd76509d082821202bb5ddf0
pkgname=$_pkgname-git
-pkgver=r932.5a0a075
+pkgver=r1063.b5434cb
pkgrel=1
pkgdesc="syntax-aware diff that also provides a number of additional tools (zs-diff, zs-find, zs-gdiff, zs-hi, zs-stats)"
arch=(x86_64)
url="https://github.com/xaizek/zograscope"
license=('AGPL')
-depends=('qt5-base' 'libgit2' 'boost-libs')
-makedepends=('git' 'boost' 'srcml')
+depends=('qt5-base' 'libgit2' 'boost-libs' 'ncurses')
+makedepends=('git' 'boost' 'srcml' 'bison')
optdepends=('srcml: srcML related diff features')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
-source=("zograscope::git+$url.git#commit=$_commit")
-md5sums=('SKIP')
+source=("zograscope::git+$url.git"
+"cursed::https://code.reversed.top/user/xaizek/libcursed"
+"vle::https://code.reversed.top/user/xaizek/libvle")
+md5sums=('SKIP'
+ '896020e55eddd4a60c6a2f049b69428d'
+ '76209f61ab1f0dbee12c68b238cf0d1d')
# Please refer to the 'USING VCS SOURCES' section of the PKGBUILD man page for
# a description of each element in the source array.
@@ -26,13 +29,17 @@ pkgver() {
prepare() {
cd "$srcdir/${_pkgname}"
+ git submodule init
+ git config submodule.tools.tui.libs.vle "${srcdir}/vle"
+ git config submodule.tools.tui.libs.cursed "${srcdir}/cursed"
+ git submodule update
echo 'QT5_PROG := qmake-qt5' >> config.mk
echo 'HAVE_LIBGIT2 := yes' >> config.mk
+ echo 'HAVE_CURSESW := yes' >> config.mk
}
build() {
cd "$srcdir/${_pkgname}"
- #make LDFLAGS="$LDFLAGS" release
make release
}