summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSabu Siyad2022-01-07 20:02:33 +0530
committerSabu Siyad2022-01-07 20:06:50 +0530
commit279586d58fb802f74a0cdbeff62b2d6d47f2eef3 (patch)
treeeecac128389ef9625b5fdacc579b8f94b17152c3
parent3f7b6b58dcb40a9c3d781ef5c5376b2ff761f4b4 (diff)
downloadaur-279586d58fb802f74a0cdbeff62b2d6d47f2eef3.tar.gz
adopt zoho-mail-desktop
-rw-r--r--.SRCINFO11
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD15
3 files changed, 16 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6aab416078a9..6100c6ea2241 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,13 @@
pkgbase = zoho-mail-desktop
pkgdesc = The desktop version of your favorite mailsuite!
- pkgver = 1.2.0
- pkgrel = 10
+ pkgver = 1.3.2
+ pkgrel = 1
url = https://www.zoho.com/mail/
arch = x86_64
license = custom
- source = https://downloads.zohocdn.com/zmail-desktop/linux/zoho-mail-desktop-x64-v1.2.0.AppImage
+ source = https://downloads.zohocdn.com/zmail-desktop/linux/zoho-mail-desktop-x64-v1.3.2.AppImage
source = zoho-mail-desktop.desktop
- sha256sums = SKIP
- sha256sums = SKIP
+ sha256sums = dae9930e6dad8b0489599d3fb58415b9562ae3e2ed1ed8af76c9e4d86db21ec0
+ sha256sums = 7be356bb7774e196b33eaeb9c2f641023c72961c00158f753777dc6135240324
pkgname = zoho-mail-desktop
-
diff --git a/.gitignore b/.gitignore
index 7861b8d0bffe..204d355cd99b 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,3 +2,5 @@ pkg/
src/
*.deb
*.pkg.tar*
+*.zst
+*.AppImage \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index 62847a4994d5..6ffb75e5a7ea 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,13 @@
-# Maintainer: Hunter Wittenborn <hunter@hunterwittenborn.me>
+# Maintainer: Sabu Siyad <hello@ssiyad.com>
+# This PKGBUILD is maintained at https://github.com/ssiyad/pkgbuilds/
+
+# Past Maintainer: Hunter Wittenborn <hunter@hunterwittenborn.me>
# Past Maintainer: Emerson Almeida <duke.m16@gmail.com>
# Past Contributor: Emerson Almeida <duke.m16@gmail.com>
pkgname=zoho-mail-desktop
-pkgver=1.2.0
-pkgrel=10
+pkgver=1.3.2
+pkgrel=1
pkgdesc="The desktop version of your favorite mailsuite!"
arch=('x86_64')
license=('custom')
@@ -12,8 +15,8 @@ url="https://www.zoho.com/mail/"
source=("https://downloads.zohocdn.com/zmail-desktop/linux/zoho-mail-desktop-x64-v${pkgver}.AppImage"
"zoho-mail-desktop.desktop")
-sha256sums=("SKIP"
- "SKIP")
+sha256sums=("d57b105779c2e33e6df5426bdcab05ec0db8e311adbbcd0f2bb38c982d11fcca"
+ "7be356bb7774e196b33eaeb9c2f641023c72961c00158f753777dc6135240324")
prepare() {
chmod +x "zoho-mail-desktop-x64-v${pkgver}.AppImage"
@@ -32,7 +35,7 @@ package() {
mkdir -p "${pkgdir}/usr/share/applications"
cp -Lr "${srcdir}/zoho-mail-desktop.desktop" "${pkgdir}/usr/share/applications"
- for img in 1024x1024 128x128 16x16 24x24 256x256 32x32 48x48 512x512 64x64 96x96; do
+ for img in 1024x1024 128x128 16x16 256x256 32x32 48x48 512x512 64x64; do
mkdir -p "${pkgdir}/usr/share/icons/hicolor/${img}/apps"
cp -Lr "${srcdir}/squashfs-root/usr/share/icons/hicolor/${img}/apps/zoho-mail-desktop.png" "${pkgdir}/usr/share/icons/hicolor/${img}/apps/"
done