summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJay Ta'ala2021-02-23 08:01:40 +1100
committerJay Ta'ala2021-02-23 09:48:08 +1100
commit5577e996de6b6a91a882e2fb2d11edabd7db3067 (patch)
treea810980a358e58ff207d403a81733deac6ea0ebc
downloadaur-5577e996de6b6a91a882e2fb2d11edabd7db3067.tar.gz
Version 1.2.0
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD23
-rw-r--r--notebook.install25
4 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a02a4bff7de9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = zoho-notebook
+ pkgdesc = Zoho Notebook for Linux: Take notes, add files, create checklists, sketches, record audio, and capture moments.
+ pkgver = 1.2.0
+ pkgrel = 1
+ url = https://www.zoho.com/notebook
+ install = notebook.install
+ arch = x86_64
+ license = custom
+ depends = gtk3
+ depends = libsecret
+ depends = dbus-x11
+ depends = libxss
+ depends = nss
+ options = !strip
+ options = !emptydirs
+ source = https://downloads.zohocdn.com/notebooklinux-desktop/Notebook-1.2.0.deb
+ sha256sums = f795bfd02c4f887735136eefd37ea19b075aee223309e727ea9f76970a8260c3
+
+pkgname = zoho-notebook
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f93fb273d272
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg/
+src/
+*.deb
+*.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fb6957c1a562
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Jay Ta'ala <jay@jaytaala.com>
+
+pkgname=zoho-notebook
+pkgver=1.2.0
+pkgrel=1
+pkgdesc="Zoho Notebook for Linux: Take notes, add files, create checklists, sketches, record audio, and capture moments."
+arch=('x86_64')
+url="https://www.zoho.com/notebook"
+license=('custom')
+depends=('gtk3' 'libsecret' 'dbus-x11' 'libxss' 'nss')
+options=('!strip' '!emptydirs')
+install=notebook.install
+source=("https://downloads.zohocdn.com/notebooklinux-desktop/Notebook-${pkgver}.deb")
+sha256sums=('f795bfd02c4f887735136eefd37ea19b075aee223309e727ea9f76970a8260c3')
+
+package() {
+ tar xf data.tar.xz -C "${pkgdir}"
+
+ # install licenses
+ install -D -m644 "${pkgdir}/opt/Notebook/resources/app.asar.unpacked/node_modules/sqlite3/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -D -m644 "${pkgdir}/opt/Notebook/LICENSE.electron.txt" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.electron.txt"
+ install -D -m644 "${pkgdir}/opt/Notebook/LICENSES.chromium.html" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSES.chromium.html"
+}
diff --git a/notebook.install b/notebook.install
new file mode 100644
index 000000000000..754b7a8ca43c
--- /dev/null
+++ b/notebook.install
@@ -0,0 +1,25 @@
+post_install() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+
+ # Link to the binary
+ ln -sf '/opt/Notebook/notebook' '/usr/bin/notebook'
+
+ # SUID chrome-sandbox for Electron 5+
+ chmod 4755 '/opt/Notebook/chrome-sandbox' || true
+
+ update-mime-database /usr/share/mime || true
+ update-desktop-database /usr/share/applications || true
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+
+ # Delete the link to the binary
+ rm -f '/usr/bin/notebook'
+ update-desktop-database -q
+}