summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNika Topolchanskaya2017-08-19 20:05:19 +0300
committerNika Topolchanskaya2017-08-19 20:05:19 +0300
commitabaebef6f3f13edcd9ae0a0e5ad0df1dfef61d0a (patch)
tree2ce7ad3e9ddab3ada7c5fc8cf222c1971af9b50d
downloadaur-abaebef6f3f13edcd9ae0a0e5ad0df1dfef61d0a.tar.gz
Initial push
-rw-r--r--.SRCINFO32
-rw-r--r--PKGBUILD43
-rw-r--r--checkpoints.patch52
-rw-r--r--db48.patch10
-rw-r--r--miniupnpc.patch25
-rw-r--r--quotefix.patch178
-rw-r--r--zoin.desktop8
7 files changed, 348 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4fce094a2c92
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,32 @@
+pkgbase = zoin
+ pkgdesc = The Zoin Cryptocurrency wallet, Qt GUI
+ pkgver = 0.8.7.5
+ pkgrel = 1
+ url = https://github.com/zoincoin/zoin
+ arch = any
+ license = MIT
+ makedepends = wget
+ makedepends = unzip
+ depends = db4.8
+ depends = boost
+ depends = miniupnpc
+ depends = qt5-base
+ depends = qt5-tools
+ depends = openssl-1.0
+ provides = zoin
+ conflicts = zoin
+ source = https://github.com/zoincoin/zoin/releases/download/v0.8.7.5/zoin-master-src-0875.zip
+ source = quotefix.patch
+ source = miniupnpc.patch
+ source = db48.patch
+ source = checkpoints.patch
+ source = zoin.desktop
+ md5sums = 5f933ebb8d3c24a5552acd59fa99c05a
+ md5sums = 71e2036b56f992edee08003ea39491e3
+ md5sums = 5b05afe70742e8c607171281416961dc
+ md5sums = 4f0de069be24574687f1d21f4ea720b5
+ md5sums = 82f69b71a43b2cae83e7936e9135a27b
+ md5sums = 9e64ccc6310db035e153e7606a1b481b
+
+pkgname = zoin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6a6412c2d552
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Nika Topolchanskaya <nanodesuu at gmail dot com>
+# Contributor: PKGBUILD based on zcoin-git by Timur Kiyivinski <timur at linux dot com>
+
+pkgname=zoin
+pkgver=0.8.7.5
+pkgrel=1
+pkgdesc='The Zoin Cryptocurrency wallet, Qt GUI'
+arch=('any')
+url='https://github.com/zoincoin/zoin'
+provides=('zoin')
+conflicts=('zoin')
+license=('MIT')
+depends=('db4.8' 'boost' 'miniupnpc' 'qt5-base' 'qt5-tools' 'openssl-1.0')
+makedepends=('wget' 'unzip')
+source=("https://github.com/zoincoin/zoin/releases/download/v0.8.7.5/zoin-master-src-0875.zip"
+ "quotefix.patch"
+ "miniupnpc.patch"
+ "db48.patch"
+ "checkpoints.patch"
+ "${pkgname}.desktop")
+md5sums=('5f933ebb8d3c24a5552acd59fa99c05a'
+ '71e2036b56f992edee08003ea39491e3'
+ '5b05afe70742e8c607171281416961dc'
+ '4f0de069be24574687f1d21f4ea720b5'
+ '82f69b71a43b2cae83e7936e9135a27b'
+ '9e64ccc6310db035e153e7606a1b481b')
+
+build() {
+ cd "$pkgname"-master
+ patch -p1 < ../quotefix.patch
+ patch -p1 < ../miniupnpc.patch
+ patch -p1 < ../db48.patch #Specific db4.8 include path
+ patch -p1 < ../checkpoints.patch #Blockchain checkpoints upstream update
+ chmod +x src/leveldb/build_detect_platform
+ qmake-qt5 OPENSSL_INCLUDE_PATH="/usr/include/openssl-1.0" OPENSSL_LIB_PATH="/usr/lib/openssl-1.0" -o Makefile zoin.pro
+ make
+}
+
+package() {
+ install -Dm755 "$srcdir/$pkgname-master/zoin" "$pkgdir/usr/bin/zoin"
+ install -Dm644 "$srcdir/$pkgname-master/src/qt/res/icons/zoin.png" "$pkgdir/usr/share/icons/zoin.png"
+ install -Dm644 "${pkgname}.desktop" "$pkgdir/usr/share/applications/${pkgname}.desktop"
+}
diff --git a/checkpoints.patch b/checkpoints.patch
new file mode 100644
index 000000000000..10428836c6d3
--- /dev/null
+++ b/checkpoints.patch
@@ -0,0 +1,52 @@
+diff --git a/src/checkpoints.cpp b/src/checkpoints.cpp
+index 0c2df0c..0137823 100644
+--- a/src/checkpoints.cpp
++++ b/src/checkpoints.cpp
+@@ -37,29 +37,31 @@ namespace Checkpoints
+ static MapCheckpoints mapCheckpoints =
+ boost::assign::map_list_of
+ ( 0, uint256("0x23911212a525e3d149fcad6c559c8b17f1e8326a272a75ff9bb315c8d96433ef"))
+- ( 160, uint256("0x8789d38fb146f4fbbc2057019944eab4320c4f36a6ac8d5128a9c7ac01773784"))
+- ( 2857, uint256("0x9c88967c9070fc8271478fb554b4201ced511b5264018dfcf42211837ecb4965"))
++ ( 160, uint256("0x8789d38fb146f4fbbc2057019944eab4320c4f36a6ac8d5128a9c7ac01773784"))
++ ( 2857, uint256("0x9c88967c9070fc8271478fb554b4201ced511b5264018dfcf42211837ecb4965"))
+ ( 5000, uint256("0x3bdd20e0a597ac1c30ef2aa335474d52addc4fe06850cbc9079bd76e77b0ef63"))
+- ( 10000, uint256("0xa10b137abce234ed21c2d25e64f12975f56ddc1f3ec74a3fb72bd436ec5731b0"))
+- ( 19285, uint256("0xab45de4e6e33b9ef32402c30195e23602dab87c1213c7f898dfd76054e5b55df"))
+- ( 23246, uint256("0xa1b05dc07d80ffcefa1eb7590b4a45d0ded23d5f6ca0824531a11aea3838200f"))
+- ( 27962, uint256("0x2dbe39206eaa0c0f12683f3fde9a9d51a0e8700be6c8f393d881870e8810e4d4"))
+- ( 27982, uint256("0xf288dccbf7593f7c98988a69868382607e2aadb86942958ed37a25f32279505d"))
+- ( 27996, uint256("0xfed132c4ef97a1512b41662fbfd1a6c9c8edb1a04b577813d572abf24070bfa1"))
+- ( 30643, uint256("0xcb2482dc59053afccb109d986ab060e9920e25be384dbc162d15975c08928133"))
+- ( 31716, uint256("0x43aabee008f19b9f403aa3f510c1ae8eb364b23fad9b35dc326b6a33bcb11379"))
+- ( 38232, uint256("0x7e30df00017ff5fcee8f09686e2879dc5912f2422e5ba51fc1285a6d54379f18"))
+- ( 43002, uint256("0x36cc81be0ba984d308a4b37c3b799d714436f79b76a0469a8abb12f1730431bb"))
+- ( 66120, uint256("0x2a25932779f36adfb18829df71d89e0443680706921a9febd5bbfc72c3de0a53"))
+- ( 70561, uint256("0xb68502e11080bab864e516fb289685b7a389fe5f23843f85167774fd74a0cd52"))
++ ( 10000, uint256("0xa10b137abce234ed21c2d25e64f12975f56ddc1f3ec74a3fb72bd436ec5731b0"))
++ ( 19285, uint256("0xab45de4e6e33b9ef32402c30195e23602dab87c1213c7f898dfd76054e5b55df"))
++ ( 23246, uint256("0xa1b05dc07d80ffcefa1eb7590b4a45d0ded23d5f6ca0824531a11aea3838200f"))
++ ( 27962, uint256("0x2dbe39206eaa0c0f12683f3fde9a9d51a0e8700be6c8f393d881870e8810e4d4"))
++ ( 27982, uint256("0xf288dccbf7593f7c98988a69868382607e2aadb86942958ed37a25f32279505d"))
++ ( 27996, uint256("0xfed132c4ef97a1512b41662fbfd1a6c9c8edb1a04b577813d572abf24070bfa1"))
++ ( 30643, uint256("0xcb2482dc59053afccb109d986ab060e9920e25be384dbc162d15975c08928133"))
++ ( 31716, uint256("0x43aabee008f19b9f403aa3f510c1ae8eb364b23fad9b35dc326b6a33bcb11379"))
++ ( 38232, uint256("0x7e30df00017ff5fcee8f09686e2879dc5912f2422e5ba51fc1285a6d54379f18"))
++ ( 43002, uint256("0x36cc81be0ba984d308a4b37c3b799d714436f79b76a0469a8abb12f1730431bb"))
++ ( 66120, uint256("0x2a25932779f36adfb18829df71d89e0443680706921a9febd5bbfc72c3de0a53"))
++ ( 70561, uint256("0xb68502e11080bab864e516fb289685b7a389fe5f23843f85167774fd74a0cd52"))
++ ( 100013, uint256("0x356eb4cf425ff78a2d6657784cfcd504dfbe1113a477c5f23caaf2e67636b6f6"))
++ ( 100980, uint256("0x568b5969a6c473d9d63b0e68e7f054efbc254c3201872d177985549aaa7bc9f9"))
+
+ ;
+ static const CCheckpointData data = {
+ &mapCheckpoints,
+ 1489943581, // * UNIX timestamp of last checkpoint block
+- 96841, // * total number of transactions between genesis and last checkpoint
++ 157916, // * total number of transactions between genesis and last checkpoint
+ // (the tx=... number in the SetBestChain debug.log lines)
+- 500 // * estimated number of transactions per day after checkpoint //1152.0
++ 762 // * estimated number of transactions per day after checkpoint //1152.0
+ };
+
+ static MapCheckpoints mapCheckpointsTestnet =
diff --git a/db48.patch b/db48.patch
new file mode 100644
index 000000000000..c7fdef870d81
--- /dev/null
+++ b/db48.patch
@@ -0,0 +1,10 @@
+--- zoin-master.orig/zoin.pro 2017-08-15 14:55:00.418339681 +0300
++++ zoin-master/zoin.pro 2017-08-15 13:27:58.340418391 +0300
+@@ -33,6 +33,7 @@ isEmpty( USE_IPV6 ) {
+ # BOOST_INCLUDE_PATH, BOOST_LIB_PATH, BDB_INCLUDE_PATH,
+ # BDB_LIB_PATH, OPENSSL_INCLUDE_PATH and OPENSSL_LIB_PATH respectively
+
++BDB_INCLUDE_PATH=/usr/include/db4.8
+ BDB_LIB_SUFFIX=-4.8
+
+ win32 {
diff --git a/miniupnpc.patch b/miniupnpc.patch
new file mode 100644
index 000000000000..016532b5ea2a
--- /dev/null
+++ b/miniupnpc.patch
@@ -0,0 +1,25 @@
+diff --git a/src/net.cpp b/src/net.cpp
+index 2b4b601..be721ea 100644
+--- a/src/net.cpp
++++ b/src/net.cpp
+@@ -1079,13 +1079,15 @@ void ThreadMapPort()
+ struct UPNPDev * devlist = 0;
+ char lanaddr[64];
+
+-#ifndef UPNPDISCOVER_SUCCESS
+- /* miniupnpc 1.5 */
+- devlist = upnpDiscover(2000, multicastif, minissdpdpath, 0);
+-#else
+- /* miniupnpc 1.6 */
++// see apiversions.txt in miniupnpc
++#if MINIUPNPC_API_VERSION >= 14
++ int error = 0;
++ devlist = upnpDiscover(2000, multicastif, minissdpdpath, 0, 0, 2, &error);
++#elif defined UPNPDISCOVER_SUCCESS
+ int error = 0;
+ devlist = upnpDiscover(2000, multicastif, minissdpdpath, 0, 0, &error);
++#elif
++ devlist = upnpDiscover(2000, multicastif, minissdpdpath, 0);
+ #endif
+
+ struct UPNPUrls urls;
diff --git a/quotefix.patch b/quotefix.patch
new file mode 100644
index 000000000000..737f87e0f843
--- /dev/null
+++ b/quotefix.patch
@@ -0,0 +1,178 @@
+From 81dde399ead44df1b0b433586c5e61be2eea7a84 Mon Sep 17 00:00:00 2001
+From: roarde <roarde@example.net>
+Date: Fri, 5 May 2017 02:04:12 -0400
+Subject: [PATCH 1/2] zoin.pro: Fix "make" option quoting; fix UPnP, QREncode,
+ and IPv6 defaults
+
+---
+ COPYING | 0
+ INSTALL | 0
+ README.md | 0
+ doc/readme-qt.rst | 19 +++++++++++++++----
+ src/libzerocoin/bitcoin_bignum/hash.cpp | 0
+ zoin.pro | 24 ++++++++++++++++--------
+ 6 files changed, 31 insertions(+), 12 deletions(-)
+ mode change 100755 => 100644 COPYING
+ mode change 100755 => 100644 INSTALL
+ mode change 100755 => 100644 README.md
+ mode change 100755 => 100644 src/libzerocoin/bitcoin_bignum/hash.cpp
+ mode change 100755 => 100644 zoin.pro
+
+diff --git a/COPYING b/COPYING
+old mode 100755
+new mode 100644
+diff --git a/INSTALL b/INSTALL
+old mode 100755
+new mode 100644
+diff --git a/README.md b/README.md
+old mode 100755
+new mode 100644
+diff --git a/doc/readme-qt.rst b/doc/readme-qt.rst
+index 6a2998b..5dfd5dd 100644
+--- a/doc/readme-qt.rst
++++ b/doc/readme-qt.rst
+@@ -85,7 +85,16 @@ Build configuration options
+ UPnP port forwarding
+ ---------------------
+
+-To use UPnP for port forwarding behind a NAT router (recommended, as more connections overall allow for a faster and more stable zoin experience), pass the following argument to qmake:
++The use of UPnP for port forwarding behind a NAT router is now the default for
++Qt builds: More connections overall allow for a faster and more stable zcoin
++experience.
++
++To build with UPnP, but have its use disabled by default, pass the
++"USE_UPNP=0" argument to qmake:
++
++ qmake "USE_UPNP=0"
++
++To build without UPnP, pass "USE_UPNP=-", instead.
+
+ ::
+
+@@ -101,9 +110,10 @@ Set USE_UPNP to a different value to control this:
+ +------------+--------------------------------------------------------------------------+
+ | USE_UPNP=- | no UPnP support, miniupnpc not required; |
+ +------------+--------------------------------------------------------------------------+
+-| USE_UPNP=0 | (the default) built with UPnP, support turned off by default at runtime; |
++| USE_UPNP=0 | build with UPnP, support turned off by default at runtime; |
+ +------------+--------------------------------------------------------------------------+
+ | USE_UPNP=1 | build with UPnP support turned on by default at runtime. |
++|(or not set)| (the default) |
+ +------------+--------------------------------------------------------------------------+
+
+ Notification support for recent (k)ubuntu versions
+@@ -119,14 +129,15 @@ FreeDesktop notification interface through DBUS using the following qmake option
+ Generation of QR codes
+ -----------------------
+
++The use of libqrencode is now the default.
+ libqrencode may be used to generate QRCode images for payment requests.
+ It can be downloaded from http://fukuchi.org/works/qrencode/index.html.en, or installed via your package manager. Pass the USE_QRCODE
+ flag to qmake to control this:
+
+ +--------------+--------------------------------------------------------------------------+
+-| USE_QRCODE=0 | (the default) No QRCode support - libarcode not required |
++| USE_QRCODE=0 | No QRCode support - libarcode not required |
+ +--------------+--------------------------------------------------------------------------+
+-| USE_QRCODE=1 | QRCode support enabled |
++| USE_QRCODE=1 | QRCode support enabled (the default) |
+ +--------------+--------------------------------------------------------------------------+
+
+
+diff --git a/src/libzerocoin/bitcoin_bignum/hash.cpp b/src/libzerocoin/bitcoin_bignum/hash.cpp
+old mode 100755
+new mode 100644
+diff --git a/zoin.pro b/zoin.pro
+old mode 100755
+new mode 100644
+index 09013b2..1266ac9
+--- a/zoin.pro
++++ b/zoin.pro
+@@ -12,9 +12,16 @@ CONFIG += no_include_pwd
+ CONFIG += thread
+ CONFIG += static
+
+-USE_QRCODE=1
+-USE_UPNP=1
+-USE_IPV6=1
++## New Defaults: Use QRCodes; build and enable UPNP and IPV6
++isEmpty( USE_QRCODE ) {
++ USE_QRCODE = 1
++}
++isEmpty( USE_UPNP ) {
++ USE_UPNP = 1
++}
++isEmpty( USE_IPV6 ) {
++ USE_IPV6=1
++}
+
+ # for boost 1.37, add -mt to the boost libraries
+ # use: qmake BOOST_LIB_SUFFIX=-mt
+@@ -38,8 +45,8 @@ win32 {
+ OPENSSL_LIB_PATH=C:/deps/openssl-1.0.2k
+ MINIUPNPC_INCLUDE_PATH=C:/deps
+ MINIUPNPC_LIB_PATH=C:/deps/miniupnpc
+- QRENCODE_INCLUDE_PATH=C:\deps\qrencode-3.4.4
+- QRENCODE_LIB_PATH=C:\deps\qrencode-3.4.4\.libs
++ QRENCODE_INCLUDE_PATH=C:/deps/qrencode-3.4.4
++ QRENCODE_LIB_PATH=C:/deps/qrencode-3.4.4/.libs
+ }
+
+
+@@ -104,7 +111,7 @@ contains(USE_UPNP, -) {
+
+ # use: qmake "USE_DBUS=1"
+ contains(USE_DBUS, 1) {
+- message(Building with DBUS (Freedesktop notifications) support)
++ message(Building with DBUS \(Freedesktop notifications\) support)
+ DEFINES += USE_DBUS
+ QT += dbus
+ }
+@@ -115,6 +122,7 @@ contains(USE_DBUS, 1) {
+ contains(USE_IPV6, -) {
+ message(Building without IPv6 support)
+ } else {
++ message(Building with IPv6 support)
+ count(USE_IPV6, 0) {
+ USE_IPV6=1
+ }
+@@ -130,14 +138,14 @@ INCLUDEPATH += src/leveldb/include src/leveldb/helpers
+ LIBS += $$PWD/src/leveldb/libleveldb.a $$PWD/src/leveldb/libmemenv.a
+ !win32 {
+ # we use QMAKE_CXXFLAGS_RELEASE even without RELEASE=1 because we use RELEASE to indicate linking preferences not -O preferences
+- genleveldb.commands = cd $$PWD/src/leveldb && CC=$$QMAKE_CC CXX=$$QMAKE_CXX $(MAKE) OPT="$$QMAKE_CXXFLAGS $$QMAKE_CXXFLAGS_RELEASE" libleveldb.a libmemenv.a
++ genleveldb.commands = cd $$PWD/src/leveldb && CC=$$QMAKE_CC CXX=$$QMAKE_CXX $(MAKE) OPT=\"$$QMAKE_CXXFLAGS $$QMAKE_CXXFLAGS_RELEASE\" libleveldb.a libmemenv.a
+ } else {
+ # make an educated guess about what the ranlib command is called
+ isEmpty(QMAKE_RANLIB) {
+ QMAKE_RANLIB = $$replace(QMAKE_STRIP, strip, ranlib)
+ }
+ LIBS += -lshlwapi
+- ###genleveldb.commands = cd \"$$PWD\"/src/leveldb && CC=$$QMAKE_CC CXX=$$QMAKE_CXX TARGET_OS=OS_WINDOWS_CROSSCOMPILE $(MAKE) OPT=\"$$QMAKE_CXXFLAGS $$QMAKE_CXXFLAGS_RELEASE\" libleveldb.a libmemenv.a && $$QMAKE_RANLIB \"$$PWD\"/src/leveldb/libleveldb.a && $$QMAKE_RANLIB \"$$PWD\"/src/leveldb/libmemenv.a
++ ###genleveldb.commands = cd $$PWD/src/leveldb && CC=$$QMAKE_CC CXX=$$QMAKE_CXX TARGET_OS=OS_WINDOWS_CROSSCOMPILE $(MAKE) OPT=\"$$QMAKE_CXXFLAGS $$QMAKE_CXXFLAGS_RELEASE\" libleveldb.a libmemenv.a && $$QMAKE_RANLIB $$PWD/src/leveldb/libleveldb.a && $$QMAKE_RANLIB $$PWD/src/leveldb/libmemenv.a
+ }
+ genleveldb.target = $$PWD/src/leveldb/libleveldb.a
+ genleveldb.depends = FORCE
+
+From cf7a0d4fe4462af8f1e11628bf955e009725e3c5 Mon Sep 17 00:00:00 2001
+From: roarde <roarde@example.net>
+Date: Fri, 16 Jun 2017 02:33:08 -0400
+Subject: [PATCH 2/2] zcoin/zoin typo
+
+---
+ doc/readme-qt.rst | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/doc/readme-qt.rst b/doc/readme-qt.rst
+index 5dfd5dd..29ac82b 100644
+--- a/doc/readme-qt.rst
++++ b/doc/readme-qt.rst
+@@ -86,7 +86,7 @@ UPnP port forwarding
+ ---------------------
+
+ The use of UPnP for port forwarding behind a NAT router is now the default for
+-Qt builds: More connections overall allow for a faster and more stable zcoin
++Qt builds: More connections overall allow for a faster and more stable zoin
+ experience.
+
+ To build with UPnP, but have its use disabled by default, pass the
diff --git a/zoin.desktop b/zoin.desktop
new file mode 100644
index 000000000000..5217aeaee448
--- /dev/null
+++ b/zoin.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Type=Application
+Name=Zoin
+Comment=The Zoin Cryptocurrency
+Exec=/usr/bin/zoin
+Terminal=false
+Icon=zoin
+Categories=Network