summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortomwei72021-03-29 23:54:04 +0800
committertomwei72021-03-29 23:55:24 +0800
commit4c645b2862b352d7c7573b46469110dad45031fc (patch)
tree703ffe82fa83fb67a76bf7b965a70faabe5d80d2
parent5e7024ba94e304e2b23bf6c4bf49349e15870df7 (diff)
downloadaur-4c645b2862b352d7c7573b46469110dad45031fc.tar.gz
zonefs-tools v1.5.0
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD102
-rw-r--r--zonefs-tools.changelog16
3 files changed, 48 insertions, 89 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a7b8024e9c67..0131575ac13c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,15 @@
-pkgbase = pkgbase
- pkgdesc = Japanese-Russian kanji and word dictionary
- pkgver = 1.10
+pkgbase = zonefs-tools
+ pkgdesc = This project provides the mkzonefs command line utility which allows formatting zoned block devices for use withe the zonefs file system.
+ pkgver = 1.5.0
pkgrel = 1
- url = http://www.susi.ru/yarxi/
+ url = https://github.com/damien-lemoal/zonefs-tools
+ changelog = zonefs-tools.changelog
arch = x86_64
- license = custom
- depends = ttf-sazanami
- depends = nas
+ license = GPL
+ depends = glibc
+ depends = util-linux-libs
+ source = zonefs-tools-1.5.0.tar.gz::https://github.com/damien-lemoal/zonefs-tools/archive/refs/tags/v1.5.0.tar.gz
+ md5sums = 75c00e15d263122486342d96ee38b487
-pkgname = yarxi
+pkgname = zonefs-tools
diff --git a/PKGBUILD b/PKGBUILD
index e21a86c2f396..9a856c088a45 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,89 +1,29 @@
-# Maintainer Seva Alekseyev <sevaa@yarxi.ru>
-# Maintainer Stoyan Minaev <stoyan.minaev@gmail.com>
-
-pkgbase=pkgbase
-pkgname=yarxi
-pkgver=1.10
+# Maintainer: tomwei7 <tomwei7g@gmail.com>
+pkgname=zonefs-tools
+pkgver=1.5.0
pkgrel=1
-pkgdesc="Japanese-Russian kanji and word dictionary"
-url="http://www.susi.ru/yarxi/"
-license=('custom')
-_source=(
- "http://www.susi.ru/yarxi/yarxi_${pkgver}-${pkgrel}_amd64.deb"
- "http://ftp.uk.debian.org/debian/pool/main/q/qt4-x11/libqtcore4_4.8.7+dfsg-11_amd64.deb"
- "http://ftp.uk.debian.org/debian/pool/main/q/qt4-x11/libqtgui4_4.8.7+dfsg-11_amd64.deb"
- "http://ftp.uk.debian.org/debian/pool/main/q/qt4-x11/libqt4-network_4.8.7+dfsg-11_amd64.deb"
-)
-arch=('x86_64')
-_md5sums=(
- '812d2265816ed781751c5c0eb6664d91'
- 'b243ada8569b2b3d4586dc4178fd8d56'
- '797e351a57c9d56368f710e7cba40f21'
- 'b3cff12767e21d3a76794046557d3df0'
-)
-depends=(
- ttf-sazanami nas
-)
+pkgdesc="This project provides the mkzonefs command line utility which allows formatting zoned block devices for use withe the zonefs file system."
+arch=("x86_64")
+url="https://github.com/damien-lemoal/zonefs-tools"
+license=("GPL")
+changelog=$pkgname.changelog
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/damien-lemoal/$pkgname/archive/refs/tags/v$pkgver.tar.gz")
+md5sums=("75c00e15d263122486342d96ee38b487")
+depends=("glibc" "util-linux-libs")
-prepare() {
- cd $srcdir/
- echo "Due to 'makepkg' and 'PKGBUILD' specs limitations I need to dowanload sources and validate them by myself"
- for source_url in ${_source[@]}; do
- source_filename=${source_url##*/}
- if [ ! -f "$source_filename" ]; then
- echo "Downloading next source - $source_filename ..."
- curl -A DUMMY -O "$source_url";
- else
- echo "Found already downloaded source - $source_filename"
- fi
- done
- echo "And now we must validated dowanloaded sources ..."
- for (( i=0; i<${#_source[@]}; ++i )); do
- source_url=${_source[i]}
- source_filename=${source_url##*/}
- source_expected_md5sum=${_md5sums[i]}
- source_actual_md5sum=$(md5sum $source_filename | awk '{print $1}')
- if [ "$source_actual_md5sum" == "$source_expected_md5sum" ]; then
- echo "Validated next source - $source_filename"
- else
- echo "Found corrupted source - $source_filename"; return 1
- fi
- done
+build() {
+ cd "$pkgname-$pkgver"
+ ./autogen.sh && ./configure --prefix=/usr
+ make -j$(nproc)
}
-build() {
- cd $srcdir/
- mkdir -p deb/{$pkgname,qt4core,qt4gui,qt4network}
- bsdtar xf yarxi_${pkgver}-${pkgrel}_amd64.deb -C deb/$pkgname/
- bsdtar xf libqtcore4_4.8.7+dfsg-11_amd64.deb -C deb/qt4core/
- bsdtar xf libqtgui4_4.8.7+dfsg-11_amd64.deb -C deb/qt4gui/
- bsdtar xf libqt4-network_4.8.7+dfsg-11_amd64.deb -C deb/qt4network/
- for dir in deb/$pkgname deb/qt4core deb/qt4gui deb/qt4network; do
- cd $dir; tar xf data.tar.*; cd $srcdir
- done
+check() {
+ cd "$pkgname-$pkgver"
+ make -k check
}
package() {
- cd $srcdir/
- mkdir -p $pkgdir/usr/lib/
- mkdir -p $pkgdir/usr/bin/
- mkdir -p $pkgdir/usr/share/
- mkdir -p $pkgdir/usr/share/applications/
- mkdir -p $pkgdir/usr/share/doc/$pkgname/
- mkdir -p $pkgdir/usr/share/icons/hicolor/{16x16/apps,32x32/apps,48x48/apps}/
- mkdir -p $pkgdir/usr/share/pixmaps/
- mkdir -p $pkgdir/usr/share/$pkgname/
- install -m 0755 $srcdir/deb/$pkgname/usr/bin/$pkgname $pkgdir/usr/bin/$pkgname
- install -m 0755 $srcdir/deb/qt4core/usr/lib/x86_64-linux-gnu/libQtCore.so.4.8.7 $pkgdir/usr/lib/libQtCore.so.4
- install -m 0755 $srcdir/deb/qt4gui/usr/lib/x86_64-linux-gnu/libQtGui.so.4.8.7 $pkgdir/usr/lib/libQtGui.so.4
- install -m 0755 $srcdir/deb/qt4network/usr/lib/x86_64-linux-gnu/libQtNetwork.so.4.8.7 $pkgdir/usr/lib/libQtNetwork.so.4
- install -m 0644 $srcdir/deb/$pkgname/usr/share/applications/seva-yarxi.desktop $pkgdir/usr/share/applications/
- install -m 0644 $srcdir/deb/$pkgname/usr/share/doc/$pkgname/copyright $pkgdir/usr/share/doc/$pkgname/
- for icons in 16x16 32x32 48x48; do
- install -m 0644 $srcdir/deb/$pkgname/usr/share/icons/hicolor/$icons/apps/seva-yarxi.png $pkgdir/usr/share/icons/hicolor/$icons/apps/
- done
- install -m 0644 $srcdir/deb/$pkgname/usr/share/pixmaps/*.xpm $pkgdir/usr/share/pixmaps/
- install -m 0644 $srcdir/deb/$pkgname/usr/share/$pkgname/yarxice.db $pkgdir/usr/share/$pkgname/
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+ mv $pkgdir/usr/sbin $pkgdir/usr/bin
}
-
-#vim: syntax=sh
diff --git a/zonefs-tools.changelog b/zonefs-tools.changelog
new file mode 100644
index 000000000000..ec0d9bdef2e8
--- /dev/null
+++ b/zonefs-tools.changelog
@@ -0,0 +1,16 @@
+### v1.5.0
+
+This new release fixes some problems with mkzonefs and improves the test suite.
+In more details:
+
+mkzonefs:
+- Improved zone reset handling, forcing an all zone reset, always.
+- Use O_EXCL mode flag to open a device file to avoid formatting a device in use.
+Fix make install directive
+- Add the new make rpm directive
+Test suite:
+- New zio tool to execute IO operations of various types using various flags
+- Fix stale data access when running tests
+- zonefs-tests-nullblk.sh improvements (new options)
+- Add test cases related to using zonefs files as swap files
+- Various other minor improvements.