summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Michalopoulos2020-01-25 18:37:41 +0200
committerAlexander Michalopoulos2020-01-25 18:37:41 +0200
commit8fe1da5d00326ae83d9bdb5d1464f460a7749760 (patch)
tree534cb8ce6a034932df429fdfa1a40ba2a2f8d9ce
parent43d4d3410eb4ac2133d1101aa49324a26c672045 (diff)
downloadaur-8fe1da5d00326ae83d9bdb5d1464f460a7749760.tar.gz
v=1.34.1,r=1
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD7
-rw-r--r--zmsetup.sh2
3 files changed, 10 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8242e3df1041..b3982abd97b4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = zoneminder
pkgdesc = A full-featured, open source, state-of-the-art video surveillance software system
- pkgver = 1.34.0
+ pkgver = 1.34.1
pkgrel = 1
url = https://www.zoneminder.com/
install = zoneminder.install
@@ -48,12 +48,13 @@ pkgbase = zoneminder
optdepends = spawn-fcgi: required if using nginx
optdepends = multiwatch: required if using nginx
optdepends = pod2man: required for Docker support
- optdepends = vlc: provides libvlc, may achieve better performance with some camera models
+ optdepends = zmeventnotification-git: machine learning powered recognition engine & event notification server
+ optdepends = vlc: provides libvlc, which may achieve better performance with some camera models
conflicts = zoneminder-git
backup = etc/nginx/sites-available/zoneminder.conf
backup = etc/httpd/conf/extra/zoneminder.conf
backup = etc/php/conf.d/zoneminder.ini
- source = git+https://github.com/ZoneMinder/zoneminder.git#tag=1.34.0
+ source = git+https://github.com/ZoneMinder/zoneminder.git#tag=1.34.1
source = zoneminder-nginx.conf
source = zoneminder-httpd.conf
source = zoneminder-php.ini
@@ -68,7 +69,7 @@ pkgbase = zoneminder
sha256sums = 3e4de227e3154dffa887f2286c339ab3cf456f6d74a400b2786192b7e2b129c0
sha256sums = b69ac1deaaf3cf84b4ae4dbab794e1b062823de817f1e3a816ccf5438db440c0
sha256sums = e95f9bef77aef647dd633bd9ad75dc099b6d7184684e133f2f20702de83a6260
- sha256sums = ac92fc44d3b6a90eeeed42aaf1b4b992a45168db1eb5be48444c635d6c1d3ab6
+ sha256sums = 255374c400e01c7666cc7b3e1f06da8445dc57afda631868d33ced62ba631c98
pkgname = zoneminder
diff --git a/PKGBUILD b/PKGBUILD
index 3434997e183e..d9ddbe3b2d24 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -43,7 +43,7 @@
pkgname=zoneminder
-pkgver=1.34.0
+pkgver=1.34.1
pkgrel=1
pkgdesc='A full-featured, open source, state-of-the-art video surveillance software system'
arch=('any')
@@ -71,7 +71,8 @@ optdepends=('mariadb'
'spawn-fcgi: required if using nginx'
'multiwatch: required if using nginx'
'pod2man: required for Docker support'
- 'vlc: provides libvlc, may achieve better performance with some camera models')
+ 'zmeventnotification-git: machine learning powered recognition engine & event notification server'
+ 'vlc: provides libvlc, which may achieve better performance with some camera models')
conflicts=('zoneminder-git')
backup=("etc/nginx/sites-available/$pkgname.conf"
"etc/httpd/conf/extra/$pkgname.conf"
@@ -92,7 +93,7 @@ sha256sums=('SKIP'
'3e4de227e3154dffa887f2286c339ab3cf456f6d74a400b2786192b7e2b129c0'
'b69ac1deaaf3cf84b4ae4dbab794e1b062823de817f1e3a816ccf5438db440c0'
'e95f9bef77aef647dd633bd9ad75dc099b6d7184684e133f2f20702de83a6260'
- 'ac92fc44d3b6a90eeeed42aaf1b4b992a45168db1eb5be48444c635d6c1d3ab6')
+ '255374c400e01c7666cc7b3e1f06da8445dc57afda631868d33ced62ba631c98')
prepare () {
cd $pkgname
diff --git a/zmsetup.sh b/zmsetup.sh
index d25fec23cbe9..01c92c0c41d2 100644
--- a/zmsetup.sh
+++ b/zmsetup.sh
@@ -60,7 +60,7 @@ case "$choice" in
systemctl is-active --quiet fcgiwrap.socket && systemctl stop fcgiwrap.socket
systemctl is-active --quiet fcgiwrap && systemctl stop fcgiwrap
systemctl is-active --quiet fcgiwrap-multiwatch && systemctl stop fcgiwrap-multiwatch
- systemctl enable --now --quiet fcgiwrap-multiwatch && echo "* fcgiwrap-multiwatch successfully configured"
+ systemctl restart --quiet fcgiwrap-multiwatch && echo "* fcgiwrap-multiwatch successfully configured"
else
echo "ERROR: You must install Nginx, fcgiwrap, spawn-fcgi and multiwatch before using this script with the --nginx flag"
exit 1