summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTroy Will2016-01-10 13:59:50 -0800
committerTroy Will2016-01-10 13:59:50 -0800
commitad2f482b3d9cf6e66f7377665ed32ce62f6c495e (patch)
tree06a3c433304b5197d704745ba7105d7d787c814d
parentb6297f82ac641094ab3f82bba724eaba1485b8e5 (diff)
downloadaur-ad2f482b3d9cf6e66f7377665ed32ce62f6c495e.tar.gz
PKGBUILD: modify git submodule update
zoneminder.install: modify for PHP7
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD9
-rw-r--r--zoneminder.install18
3 files changed, 20 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a545b7600cba..aaa5d100e787 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Mon Jan 4 03:20:53 UTC 2016
+# Sun Jan 10 21:56:05 UTC 2016
pkgbase = zoneminder-git
pkgdesc = Capture, analyse, record and monitor video security cameras
pkgver = 1.29.0
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/ZoneMinder/ZoneMinder/releases
install = zoneminder.install
arch = i686
@@ -44,10 +44,12 @@ pkgbase = zoneminder-git
optdepends = perl-astro-suntime
backup = etc/zm.conf
source = git://github.com/zoneminder/zoneminder.git
+ source = git://github.com/FriendsOfCake/crud.git
source = httpd-zoneminder.conf
source = zoneminder.service
source = zoneminder-tmpfile.conf
sha256sums = SKIP
+ sha256sums = SKIP
sha256sums = ff7382b38ac07dadead0ad4d583e3dbcf8da4aaa06b76d048ee334f69f95db67
sha256sums = 043d77a995553c533d62f48db4b719d29cf6c7074f215d866130e97be57ed646
sha256sums = cc8af737c3c07750fc71317c81999376e4bbb39da883780164a8747b3d7c95a7
diff --git a/PKGBUILD b/PKGBUILD
index 25129f078b5b..a75cd24b281d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,7 +12,7 @@
_pkgname=zoneminder
pkgname=zoneminder-git
pkgver=1.29.0
-pkgrel=2
+pkgrel=3
pkgdesc='Capture, analyse, record and monitor video security cameras'
arch=( i686 x86_64 mips64el arm armv7h )
backup=( etc/zm.conf )
@@ -41,12 +41,14 @@ install=$_pkgname.install
source=(
git://github.com/$_pkgname/$_pkgname.git
+ git://github.com/FriendsOfCake/crud.git
httpd-zoneminder.conf
zoneminder.service
zoneminder-tmpfile.conf
)
# Because the source is not static, skip Git checksum:
sha256sums=('SKIP'
+ 'SKIP'
'ff7382b38ac07dadead0ad4d583e3dbcf8da4aaa06b76d048ee334f69f95db67'
'043d77a995553c533d62f48db4b719d29cf6c7074f215d866130e97be57ed646'
'cc8af737c3c07750fc71317c81999376e4bbb39da883780164a8747b3d7c95a7'
@@ -60,7 +62,10 @@ pkgver() {
prepare () {
cd $srcdir/$_pkgname
- git submodule update --init --recursive
+ git submodule init
+ git config submodule.web/api/app/Plugin/Crud.url $srcdir/crud
+ git config submodule.web/api/app/Plugin/Crud.branch 3.0
+ git submodule update
}
build() {
diff --git a/zoneminder.install b/zoneminder.install
index acfd93463514..d16779e3b25e 100644
--- a/zoneminder.install
+++ b/zoneminder.install
@@ -23,11 +23,11 @@ post_install() {
# Zoneminder needs Apache configured to permit CGI execution
\|^\t#LoadModule cgi_module modules/mod_cgi.so$| s|\t#|\t|;
- # libphp5
- \|^LoadModule php5_module modules/libphp5.so$|d;
- s|^#*LoadModule rewrite_module modules/mod_rewrite.so$|&\nLoadModule php5_module modules/libphp5.so|;
- \|^Include /etc/httpd/conf/extra/php5_module.conf|d;
- s|^Include conf/extra/httpd-default.conf$|&\nInclude /etc/httpd/conf/extra/php5_module.conf|;
+ # libphp7
+ \|^LoadModule php7_module modules/libphp7.so$|d;
+ s|^#*LoadModule rewrite_module modules/mod_rewrite.so$|&\nLoadModule php7_module modules/libphp7.so|;
+ \|^Include /etc/httpd/conf/extra/php7_module.conf|d;
+ s|^Include conf/extra/httpd-default.conf$|&\nInclude /etc/httpd/conf/extra/php7_module.conf|;
# Include httpd-zoneminder.conf
\|^Include /etc/httpd/conf/extra/httpd-zoneminder.conf$|d;
@@ -66,9 +66,9 @@ post_install() {
Apache configuration
--------------------
Edit /etc/httpd/conf/httpd.conf and add the line:
- "LoadModule php5_module modules/libphp5.so"
+ "LoadModule php7_module modules/libphp7.so"
and:
- "Include /etc/httpd/conf/extra/php5_module.conf"
+ "Include /etc/httpd/conf/extra/php7_module.conf"
"Include /etc/httpd/conf/extra/httpd-zoneminder.conf"
EOF
@@ -105,8 +105,8 @@ Note:
==> Disable http with php if it isn't needed with others servers,
==> comment or remove that lines in /etc/httpd/conf/httpd.conf:
-==> "LoadModule php5_module modules/libphp5.so"
-==> "Include /etc/httpd/conf/extra/php5_module.conf"
+==> "LoadModule php7_module modules/libphp7.so"
+==> "Include /etc/httpd/conf/extra/php7_module.conf"
==> Remove line in /etc/httpd/conf/httpd.conf:
==> "Include /etc/httpd/conf/extra/httpd-zoneminder.conf"