summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGordian Edenhofer2015-08-15 15:17:45 +0200
committerGordian Edenhofer2015-08-15 15:17:45 +0200
commit105d1387b2ab65c68c8d8a1fa1e35119e00e3711 (patch)
tree948eb7038425bd5c141add6b34fc07bc0274825f
downloadaur-105d1387b2ab65c68c8d8a1fa1e35119e00e3711.tar.gz
Initial package upload
-rw-r--r--.SRCINFO34
-rw-r--r--PKGBUILD28
2 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1d6868a6b287
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,34 @@
+pkgbase = zoom
+ pkgdesc = Start or join Zoom meetings
+ pkgver = 1.0.22331.0731
+ pkgrel = 1
+ url = https://zoom.us/
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = qt5-base
+ depends = qt5-webkit
+ depends = qt5-svg
+ depends = qt5-declarative
+ depends = qt5-location
+ depends = qt5-xmlpatterns
+ depends = qt5-webchannel
+ depends = qt5-sensors
+ depends = qt5-script
+ depends = glib2
+ depends = lib32-mesa
+ depends = lib32-libxcb
+ depends = lib32-libgl
+ depends = lib32-libxi
+ depends = lib32-libsm
+ depends = lib32-fontconfig
+ depends = lib32-libpulse
+ depends = lib32-libxcomposite
+ depends = lib32-libxslt
+ depends = gstreamer0.10-base-plugins
+ options = !strip
+ source = https://zoom.us/client/latest/ZoomInstaller_i386.deb
+ md5sums = 519689cc7b2b399adf12ffbe41adef46
+
+pkgname = zoom
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ad70167002c8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Gordian Edenhofer <gordian.edenhofer[at]yahoo[dot]de>
+
+pkgname=zoom
+pkgver=1.0.22331.0731
+pkgrel=1
+pkgdesc="Start or join Zoom meetings"
+arch=('i686' 'x86_64')
+license=('custom')
+url="https://zoom.us/"
+depends=('qt5-base' 'qt5-webkit' 'qt5-svg' 'qt5-declarative' 'qt5-location' 'qt5-xmlpatterns'
+ 'qt5-webchannel' 'qt5-sensors' 'qt5-script' 'glib2' 'lib32-mesa' 'lib32-libxcb'
+ 'lib32-libgl' 'lib32-libxi' 'lib32-libsm' 'lib32-fontconfig' 'lib32-libpulse'
+ 'lib32-libxcomposite' 'lib32-libxslt' 'gstreamer0.10-base-plugins')
+options=(!strip)
+source=("https://zoom.us/client/latest/ZoomInstaller_i386.deb")
+md5sums=('519689cc7b2b399adf12ffbe41adef46')
+
+package() {
+ bsdtar xf data.tar.xz
+ chmod -R g-w usr
+ mv usr "${pkgdir}"
+ chmod -R g-w opt
+ mv opt "${pkgdir}"
+
+ # Refering to the online license
+ mkdir -p "${pkgdir}"/usr/share/licenses/zoom/
+ echo "Please refer to https://zoom.us/terms for detailed license information." > "${pkgdir}"/usr/share/licenses/zoom/LICENSE
+}