summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGordian Edenhofer2017-03-10 14:09:34 +0100
committerGordian Edenhofer2017-03-10 14:09:34 +0100
commit3600575c962a82729a0a9cb558587ae14c103d1c (patch)
tree0cf8d91ea16fba71b664ec685bda83a16a8cf762
parent4cbcede73d09433ecf4c2b7608d91e3aa90bd07c (diff)
downloadaur-3600575c962a82729a0a9cb558587ae14c103d1c.tar.gz
upgpkg: zoom 2.0.81497.0116-4
Repackage the original Arch package, thereby removing i686 support since upstream is not providing a package either. The sole purpose of this PKGBUILD is to ease installation via the AUR!
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD20
2 files changed, 8 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 37f4b94d5f5a..114aa158e0d2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,8 @@
pkgbase = zoom
pkgdesc = Video Conferencing and Web Conferencing Service
pkgver = 2.0.81497.0116
- pkgrel = 3
+ pkgrel = 4
url = https://zoom.us/
- arch = i686
arch = x86_64
license = custom
depends = glib2
@@ -29,9 +28,7 @@ pkgbase = zoom
depends = libxfixes
depends = libxrender
options = !strip
- source_i686 = zoom-2.0.81497.0116_i386.deb::https://zoom.us/client/2.0.81497.0116/zoom_i386.deb
- sha512sums_i686 = aebca1f08813db2d2bc36d7bc4cd54258174cc594618c6ca72413e5010ebc3a0a8e87b78ab4eec602b877be65980e9cd90ce55c568046733b400ad3fbe2f0962
- source_x86_64 = zoom-2.0.81497.0116_amd64.deb::https://zoom.us/client/2.0.81497.0116/zoom_amd64.deb
- sha512sums_x86_64 = e9e7266860b868b693b3b1148dff0fe30f57b73e6366d376ae3a8252ac226599afeba806c58cccf893cc770c9cf00f48943b9a39f6de3b04173900fddf1e6474
+ source = zoom-2.0.81497.0116_orig_x86_64.pkg.tar.xz::https://zoom.us/client/2.0.81497.0116/zoom_x86_64.pkg.tar.xz
+ sha512sums = 98c33d78f85d3195af37c0f9233a1531e1c61ebf2bc9036c61b454b640379517c6957155314b0b7ea240280e59528e9948b04a5e7d1cd2c60c4bee3f7169f7a4
pkgname = zoom
diff --git a/PKGBUILD b/PKGBUILD
index a687ad8d3a47..4ba8125c4a45 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,28 +2,18 @@
pkgname=zoom
pkgver=2.0.81497.0116
-pkgrel=3
+pkgrel=4
pkgdesc="Video Conferencing and Web Conferencing Service"
-arch=('i686' 'x86_64')
+arch=('x86_64')
license=('custom')
url="https://zoom.us/"
depends=('glib2' 'gstreamer' 'libxcb' 'xcb-util-image' 'fontconfig' 'mesa' 'libxi' 'libsm' 'libxrender'
'libpulse' 'libxcomposite' 'libxslt' 'sqlite' 'xcb-util-keysyms' 'qt5-webengine' 'qt5-svg'
'pulseaudio-alsa' 'libx11' 'nss' 'libxshmfence' 'libxfixes' 'libxrender')
options=(!strip)
-source_i686=("${pkgname}-${pkgver}_i386.deb"::"https://zoom.us/client/${pkgver}/zoom_i386.deb")
-source_x86_64=("${pkgname}-${pkgver}_amd64.deb"::"https://zoom.us/client/${pkgver}/zoom_amd64.deb")
-sha512sums_i686=('aebca1f08813db2d2bc36d7bc4cd54258174cc594618c6ca72413e5010ebc3a0a8e87b78ab4eec602b877be65980e9cd90ce55c568046733b400ad3fbe2f0962')
-sha512sums_x86_64=('e9e7266860b868b693b3b1148dff0fe30f57b73e6366d376ae3a8252ac226599afeba806c58cccf893cc770c9cf00f48943b9a39f6de3b04173900fddf1e6474')
+source=("${pkgname}-${pkgver}_orig_x86_64.pkg.tar.xz"::"https://zoom.us/client/${pkgver}/zoom_x86_64.pkg.tar.xz")
+sha512sums=('98c33d78f85d3195af37c0f9233a1531e1c61ebf2bc9036c61b454b640379517c6957155314b0b7ea240280e59528e9948b04a5e7d1cd2c60c4bee3f7169f7a4')
package() {
- bsdtar xf data.tar.xz
- chmod -R g-w usr
- mv usr "${pkgdir}"
- chmod -R g-w opt
- mv opt "${pkgdir}"
-
- # Refering to the online license
- mkdir -p "${pkgdir}"/usr/share/licenses/zoom/
- echo "Please refer to https://zoom.us/terms for detailed license information." > "${pkgdir}"/usr/share/licenses/zoom/LICENSE
+ cp -dpr --no-preserve=ownership opt usr "${pkgdir}"
}