summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPeter Roberts2019-01-19 14:44:16 +0000
committerPeter Roberts2019-01-19 14:44:16 +0000
commitadf52cce76cdfadacd520a36c9146ccbecf3743f (patch)
tree1600e93e45f4d5ca2383f221ba59f9b856c9182f
downloadaur-adf52cce76cdfadacd520a36c9146ccbecf3743f.tar.gz
Add v0.0.4
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD34
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d103ddfd49b7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = zoom-parallel
+ pkgdesc = Parallel command executor with a focus on simplicity and good cross-platform behaviour
+ pkgver = 0.0.4
+ pkgrel = 1
+ url = https://github.com/pwr22/zoom
+ arch = x86_64
+ license = MIT
+ makedepends = go-pie
+ depends = glibc
+ source = https://github.com/pwr22/zoom/archive/v0.0.4.tar.gz
+ sha256sums = 89af374fe89ea082e6b3b9e9b1d33b0008b650378c5ea77fb1f776cc3d769802
+
+pkgname = zoom-parallel
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8a802670bdef
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Peter Roberts <me@peter-r.co.uk>
+pkgname=zoom-parallel
+pkgver=0.0.4
+pkgrel=1
+pkgdesc="Parallel command executor with a focus on simplicity and good cross-platform behaviour "
+arch=("x86_64")
+url="https://github.com/pwr22/zoom"
+license=('MIT')
+depends=("glibc")
+makedepends=("go-pie")
+source=("https://github.com/pwr22/zoom/archive/v$pkgver.tar.gz")
+sha256sums=("89af374fe89ea082e6b3b9e9b1d33b0008b650378c5ea77fb1f776cc3d769802")
+
+_cmdname=zoom # name of the command - there's a clash so the package name is longer
+
+# Go stuff based on https://wiki.archlinux.org/index.php/Go_package_guidelines#Basic_PKGBUILD
+
+build() {
+ cd "$_cmdname-$pkgver"
+ GOPATH="$srcdir/go" go build
+
+ go build \
+ -gcflags "all=-trimpath=$PWD" \
+ -asmflags "all=-trimpath=$PWD" \
+ -ldflags "-extldflags $LDFLAGS" \
+ -o "$_cmdname" .
+}
+
+package() {
+ cd "$_cmdname-$pkgver"
+ install -Dm755 "$_cmdname" "$pkgdir/usr/bin/$_cmdname"
+ mkdir -p "$pkgdir/usr/share/licenses/$pkgname"
+ cp LICENSE "$pkgdir/usr/share/licenses/$pkgname"
+}