summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakab Kristóf2015-10-25 21:33:07 +0100
committerJakab Kristóf2015-10-25 21:34:44 +0100
commita3fd35939346babd73590ef7fa58101a34ce20ae (patch)
tree318328f6b2f3bc83aa74d75b0aafd9127a95cfec
downloadaur-zorp.tar.gz
Initial commit
FIXME: - patch files should be upstream - python shebangs should be corrected to use python2 - namcap warnings should be looked at
-rw-r--r--.SRCINFO17
-rw-r--r--0001-Consider-only-python2-and-python2.7.patch25
-rw-r--r--PKGBUILD32
3 files changed, 74 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7bffff5cbe6c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = zorp
+ pkgdesc = A new generation proxy firewall suite
+ pkgver = 6.0.7
+ pkgrel = 1
+ url = https://github.com/balabit/zorp
+ arch = x86_64
+ license = GPL2
+ makedepends = gperf
+ depends = libzorpll
+ depends = python2
+ source = https://github.com/balabit/zorp/archive/v6.0.7.tar.gz
+ source = 0001-Consider-only-python2-and-python2.7.patch
+ md5sums = 0f1a27596935244efc6d43cd1285fb8c
+ md5sums = f9b828ed00f5c2e8e71ae9f965736e2b
+
+pkgname = zorp
+
diff --git a/0001-Consider-only-python2-and-python2.7.patch b/0001-Consider-only-python2-and-python2.7.patch
new file mode 100644
index 000000000000..4584dd7852d9
--- /dev/null
+++ b/0001-Consider-only-python2-and-python2.7.patch
@@ -0,0 +1,25 @@
+From dfeff2f829ce268d9b234c14c8b1bead8d746d18 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Krist=C3=B3f=20Jakab?= <jaksi@jaksi.io>
+Date: Mon, 21 Sep 2015 15:46:09 +0200
+Subject: [PATCH] Consider only python2 and python2.7
+
+---
+ configure.ac | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/configure.ac b/configure.ac
+index 73a5fb5..a529ed2 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -32,6 +32,8 @@ OPENSSL_MIN_VERSION="1.0.1"
+ PYTHON_MIN_VERSION="2.7"
+ PYTHON_MAX_VERSION="2.8"
+
++m4_define_default([_AM_PYTHON_INTERPRETER_LIST], [python2 python2.7])
++
+ dnl ***************************************************************************
+ dnl Initial setup
+
+--
+2.5.3
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..92a3017ddab9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Kristóf Jakab <jaksi@jaksi.io>
+pkgname=zorp
+pkgver=6.0.7
+pkgrel=1
+pkgdesc='A new generation proxy firewall suite'
+arch=('x86_64')
+url='https://github.com/balabit/zorp'
+license=('GPL2')
+makedepends=('gperf')
+depends=('libzorpll' 'python2')
+source=(
+ 'https://github.com/balabit/zorp/archive/v6.0.7.tar.gz'
+ '0001-Consider-only-python2-and-python2.7.patch'
+)
+md5sums=(
+ '0f1a27596935244efc6d43cd1285fb8c'
+ 'f9b828ed00f5c2e8e71ae9f965736e2b'
+)
+
+build() {
+ cd "$srcdir/zorp-6.0.7"
+ patch -p1 < '../../0001-Consider-only-python2-and-python2.7.patch'
+ ./autogen.sh
+ ./configure --prefix=/usr --sysconfdir=/etc
+ make
+}
+
+package() {
+ cd "$srcdir/zorp-6.0.7"
+ make DESTDIR="$pkgdir/" install
+ rm -r "$pkgdir/usr/var/"
+}