summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAaron Keesing2022-11-10 22:09:53 +1300
committerAaron Keesing2022-11-10 22:09:53 +1300
commit95ab48d92804c7e8ed0d731127c831b9b8f6f2d0 (patch)
tree2d2c728fe81c61244ebd74011a82fc71d871e0c8
parent04057768061b317216db71ed2cf7b653e935ff0c (diff)
downloadaur-95ab48d92804c7e8ed0d731127c831b9b8f6f2d0.tar.gz
Version 6.0.18. Fix OpenSSL 3 build issue.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
2 files changed, 5 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5deb3e3922c1..3a3ed162d050 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = zotero
pkgdesc = A free, easy-to-use tool to help you collect, organize, cite, and share your research sources.
- pkgver = 6.0.16
+ pkgver = 6.0.18
pkgrel = 1
url = https://github.com/zotero/zotero
arch = x86_64
@@ -21,7 +21,7 @@ pkgbase = zotero
depends = nss
depends = libxt
source = zotero.desktop
- source = zotero-client::git+https://github.com/zotero/zotero.git#tag=a289a11d30dc08a0dd817f4c3bd3a96547ae7956
+ source = zotero-client::git+https://github.com/zotero/zotero.git#tag=a08ef977c4ec6aa8982d12e0b16abf6d7f9dc1f0
source = zotero-build::git+https://github.com/zotero/zotero-build.git
source = zotero-standalone-build::git+https://github.com/zotero/zotero-standalone-build.git#tag=6.0.14
source = zotero-translators::git+https://github.com/zotero/translators.git
diff --git a/PKGBUILD b/PKGBUILD
index 9610d365c671..bfa6a41f0c8b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Aaron Keesing <agkphysics at gmail dot com>
pkgname=zotero
-pkgver=6.0.16
+pkgver=6.0.18
pkgrel=1
pkgdesc="A free, easy-to-use tool to help you collect, organize, cite, and share your research sources."
arch=('x86_64' 'i686')
@@ -9,7 +9,7 @@ url="https://github.com/zotero/zotero"
license=('AGPL3')
depends=('dbus-glib' 'gtk3' 'nss' 'libxt')
makedepends=('npm' 'git' 'zip' 'unzip' 'perl' 'python>=3' 'curl' 'wget' 'rsync' 'nodejs')
-_tag=a289a11d30dc08a0dd817f4c3bd3a96547ae7956 # git rev-parse $pkgver
+_tag=a08ef977c4ec6aa8982d12e0b16abf6d7f9dc1f0 # git rev-parse $pkgver
source=("zotero.desktop"
"zotero-client::git+https://github.com/zotero/zotero.git#tag=${_tag}"
"zotero-build::git+https://github.com/zotero/zotero-build.git"
@@ -95,7 +95,7 @@ prepare() {
build() {
cd "$srcdir/zotero-client"
- npm run build
+ NODE_OPTIONS=--openssl-legacy-provider npm run build
cd "$srcdir/zotero-standalone-build"
scripts/dir_build -p l