summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAaron Keesing2022-08-13 20:35:49 +1200
committerAaron Keesing2022-08-13 21:57:08 +1200
commitc2544ff3063c87b56a49e3111c917e83f6db2617 (patch)
tree772f19ff89117fa20c6da1dae68cd9a1d82ee184
parente066e9d337b363c12fd96022318eec49ad2f10f1 (diff)
downloadaur-c2544ff3063c87b56a49e3111c917e83f6db2617.tar.gz
New package at version 6.0.11.
-rw-r--r--.SRCINFO55
-rw-r--r--PKGBUILD124
-rw-r--r--zotero.install13
3 files changed, 152 insertions, 40 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 174fa5ddfbd8..a47b5bf7613c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,61 @@
pkgbase = zotero
- pkgdesc = Zotero Standalone. Is a free, easy-to-use tool to help you collect, organize, cite, and share your research sources.
- pkgver = 6.0.3
+ pkgdesc = A free, easy-to-use tool to help you collect, organize, cite, and share your research sources.
+ pkgver = 6.0.11
pkgrel = 1
- url = https://www.zotero.org/download
- install = zotero.install
+ url = https://github.com/zotero/zotero
arch = x86_64
+ arch = i686
license = AGPL3
+ makedepends = npm
+ makedepends = git
+ makedepends = zip
+ makedepends = unzip
+ makedepends = perl
+ makedepends = python>=3
+ makedepends = curl
+ makedepends = wget
+ makedepends = rsync
depends = dbus-glib
depends = gtk3
depends = nss
depends = libxt
source = zotero.desktop
+ source = zotero-client::git+https://github.com/zotero/zotero.git#tag=77796639dfa0a0fbfa8c5e4cb314df42fb80fef2
+ source = zotero-build::git+https://github.com/zotero/zotero-build.git
+ source = zotero-standalone-build::git+https://github.com/zotero/zotero-standalone-build.git
+ source = zotero-translators::git+https://github.com/zotero/translators.git
+ source = zotero-styles::git+https://github.com/zotero/bundled-styles.git
+ source = zotero-pdf-worker::git+https://github.com/zotero/pdf-worker.git
+ source = zotero-note-editor::git+https://github.com/zotero/note-editor.git
+ source = zotero-pdf-reader::git+https://github.com/zotero/pdf-reader.git
+ source = zotero-chai::git+https://github.com/chaijs/chai.git
+ source = zotero-mocha::git+https://github.com/mochajs/mocha.git
+ source = zotero-chai-as-promised::git+https://github.com/domenic/chai-as-promised.git
+ source = zotero-schema::git+https://github.com/zotero/zotero-schema.git
+ source = zotero-SingleFile::git+https://github.com/gildas-lormeau/SingleFile.git
+ source = zotero-utilities::git+https://github.com/zotero/utilities.git
+ source = zotero-translate::git+https://github.com/zotero/translate.git
+ source = zotero-csl::git+https://github.com/citation-style-language/locales.git
+ source = zotero-transfw::git+https://github.com/egh/zotero-transfw.git
+ source = zotero-libreoffice-integration::git+https://github.com/zotero/zotero-libreoffice-integration.git
sha256sums = eab76db7a56a4d9aaa17baaf240b82fcf57944a4ddf8ef1b58cc64182426cedc
- source_x86_64 = Zotero-6.0.3_linux_x86_64.tar.bz2::https://www.zotero.org/download/client/dl?channel=release&platform=linux-x86_64&version=6.0.3
- sha256sums_x86_64 = dfe3441e9b3288a7fe80fc86dbe9ca1464e0db0e6a91c89c3297cb073cf7b924
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
pkgname = zotero
diff --git a/PKGBUILD b/PKGBUILD
index e2ad4ab7b429..a9d5ad9ea82d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,116 @@
-# Maintainer: Juanma Hernandez <juanmah@gmail.com>
+# Maintainer: Aaron Keesing <agkphysics at gmail dot com>
pkgname=zotero
-pkgver=6.0.3
+pkgver=6.0.11
pkgrel=1
-pkgdesc="Zotero Standalone. Is a free, easy-to-use tool to help you collect, organize, cite, and share your research sources."
-arch=('x86_64')
-url="https://www.zotero.org/download"
+pkgdesc="A free, easy-to-use tool to help you collect, organize, cite, and share your research sources."
+arch=('x86_64' 'i686')
+url="https://github.com/zotero/zotero"
license=('AGPL3')
depends=('dbus-glib' 'gtk3' 'nss' 'libxt')
+makedepends=('npm' 'git' 'zip' 'unzip' 'perl' 'python>=3' 'curl' 'wget' 'rsync')
+_tag=77796639dfa0a0fbfa8c5e4cb314df42fb80fef2 # git rev-parse $pkgver
+source=("zotero.desktop"
+ "zotero-client::git+https://github.com/zotero/zotero.git#tag=${_tag}"
+ "zotero-build::git+https://github.com/zotero/zotero-build.git"
+ "zotero-standalone-build::git+https://github.com/zotero/zotero-standalone-build.git"
+ "zotero-translators::git+https://github.com/zotero/translators.git"
+ "zotero-styles::git+https://github.com/zotero/bundled-styles.git"
+ "zotero-pdf-worker::git+https://github.com/zotero/pdf-worker.git"
+ "zotero-note-editor::git+https://github.com/zotero/note-editor.git"
+ "zotero-pdf-reader::git+https://github.com/zotero/pdf-reader.git"
+ "zotero-chai::git+https://github.com/chaijs/chai.git"
+ "zotero-mocha::git+https://github.com/mochajs/mocha.git"
+ "zotero-chai-as-promised::git+https://github.com/domenic/chai-as-promised.git"
+ "zotero-schema::git+https://github.com/zotero/zotero-schema.git"
+ "zotero-SingleFile::git+https://github.com/gildas-lormeau/SingleFile.git"
+ "zotero-utilities::git+https://github.com/zotero/utilities.git"
+ "zotero-translate::git+https://github.com/zotero/translate.git"
+ "zotero-csl::git+https://github.com/citation-style-language/locales.git"
+ "zotero-transfw::git+https://github.com/egh/zotero-transfw.git"
+ "zotero-libreoffice-integration::git+https://github.com/zotero/zotero-libreoffice-integration.git")
+sha256sums=('eab76db7a56a4d9aaa17baaf240b82fcf57944a4ddf8ef1b58cc64182426cedc'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP')
-sha256sums=('eab76db7a56a4d9aaa17baaf240b82fcf57944a4ddf8ef1b58cc64182426cedc')
-sha256sums_x86_64=('dfe3441e9b3288a7fe80fc86dbe9ca1464e0db0e6a91c89c3297cb073cf7b924')
+pkgver() {
+ cd "$srcdir/zotero-client"
+ git describe --tags
+}
+
+prepare() {
+ cd "$srcdir/zotero-build"
+ git submodule init
+ git config submodule.xpi/zotero-transfw.url "$srcdir/zotero-transfw"
+ git submodule update
+
+ cd "$srcdir/zotero-client"
+ git submodule init
+ git config submodule.translators.url "$srcdir/zotero-translators"
+ git config submodule.styles.url "$srcdir/zotero-styles"
+ git config submodule.pdf-worker.url "$srcdir/zotero-pdf-worker"
+ git config submodule.note-editor.url "$srcdir/zotero-note-editor"
+ git config submodule.pdf-reader.url "$srcdir/zotero-pdf-reader"
+ git config submodule.test/resource/chai.url "$srcdir/zotero-chai"
+ git config submodule.test/resource/mocha.url "$srcdir/zotero-mocha"
+ git config submodule.test/resource/chai-as-promised.url "$srcdir/zotero-chai-as-promised"
+ git config submodule.resource/schema/global.url "$srcdir/zotero-schema"
+ git config submodule.resource/SingleFile.url "$srcdir/zotero-SingleFile"
+ git config submodule.chrome/content/zotero/xpcom/utilities.url "$srcdir/zotero-utilities"
+ git config submodule.chrome/content/zotero/xpcom/translate.url "$srcdir/zotero-translate"
+ git config submodule.chrome/content/zotero/locale/csl.url "$srcdir/zotero-csl"
+ git submodule update
-install='zotero.install'
+ npm i --legacy-peer-deps
+
+ cd "$srcdir/zotero-standalone-build"
+ git submodule init
+ git config submodule.modules/zotero-libreoffice-integration.url "$srcdir/zotero-libreoffice-integration"
+ git submodule update
+
+ ./fetch_xulrunner.sh -p l
+ ./fetch_pdftools
+}
-source=("zotero.desktop")
-source_x86_64=("Zotero-${pkgver}_linux_$CARCH.tar.bz2::https://www.zotero.org/download/client/dl?channel=release&platform=linux-$CARCH&version=${pkgver}")
+build() {
+ cd "$srcdir/zotero-client"
+ npm run build
+
+ cd "$srcdir/zotero-standalone-build"
+ scripts/dir_build -p l
+}
package() {
install -dDm755 "$pkgdir"/usr/{bin,lib/zotero}
- mv "$srcdir"/Zotero_linux-$CARCH/* "$pkgdir"/usr/lib/zotero
- ln -s /usr/lib/zotero/zotero "$pkgdir"/usr/bin/zotero
- install -Dm644 "$srcdir"/zotero.desktop "$pkgdir"/usr/share/applications/zotero.desktop
+ mv "$srcdir/zotero-standalone-build/staging/Zotero_linux-$CARCH"/* "$pkgdir/usr/lib/zotero"
+ ln -s /usr/lib/zotero/zotero "$pkgdir/usr/bin/zotero"
+ install -Dm644 "$srcdir/zotero.desktop" "$pkgdir/usr/share/applications/zotero.desktop"
+
# Copy zotero icons to a standard location
- install -Dm644 "$pkgdir"/usr/lib/zotero/chrome/icons/default/default16.png "$pkgdir"/usr/share/icons/hicolor/16x16/apps/zotero.png
- install -Dm644 "$pkgdir"/usr/lib/zotero/chrome/icons/default/default32.png "$pkgdir"/usr/share/icons/hicolor/32x32/apps/zotero.png
- install -Dm644 "$pkgdir"/usr/lib/zotero/chrome/icons/default/default48.png "$pkgdir"/usr/share/icons/hicolor/48x48/apps/zotero.png
- install -Dm644 "$pkgdir"/usr/lib/zotero/chrome/icons/default/default256.png "$pkgdir"/usr/share/icons/hicolor/256x256/apps/zotero.png
- # Disable APP update
- sed -i '/pref("app.update.enabled", true);/c\pref("app.update.enabled", false);' "$pkgdir"/usr/lib/zotero/defaults/preferences/prefs.js
- # No need to keep a shell around when launching Zotero
- sed -i -r 's/^("\$CALLDIR\/zotero-bin" -app "\$CALLDIR\/application.ini" "\$@")/exec \1/' "$pkgdir"/usr/lib/zotero/zotero
+ install -Dm644 "$pkgdir/usr/lib/zotero/chrome/icons/default/default16.png" "$pkgdir/usr/share/icons/hicolor/16x16/apps/zotero.png"
+ install -Dm644 "$pkgdir/usr/lib/zotero/chrome/icons/default/default32.png" "$pkgdir/usr/share/icons/hicolor/32x32/apps/zotero.png"
+ install -Dm644 "$pkgdir/usr/lib/zotero/chrome/icons/default/default48.png" "$pkgdir/usr/share/icons/hicolor/48x48/apps/zotero.png"
+ install -Dm644 "$pkgdir/usr/lib/zotero/chrome/icons/default/default256.png" "$pkgdir/usr/share/icons/hicolor/256x256/apps/zotero.png"
+
+ # Disable automatic updates
+ sed -i '/pref("app.update.enabled", true);/c\pref("app.update.enabled", false);' "$pkgdir/usr/lib/zotero/defaults/preferences/prefs.js"
+
+ # Close shell when launching
+ sed -i -r 's:^("\$CALLDIR/zotero-bin" -app "\$CALLDIR/application.ini" "\$@"):exec \1:' "$pkgdir/usr/lib/zotero/zotero"
}
diff --git a/zotero.install b/zotero.install
deleted file mode 100644
index 565a7caface3..000000000000
--- a/zotero.install
+++ /dev/null
@@ -1,13 +0,0 @@
-post_install() {
- echo "Maybe you want the context menu icons enabled. This can be done in dconf or using the CLI:"
- echo "gsettings set org.gnome.desktop.interface menus-have-icons true"
- echo "DISCLAIMER: Notice that this is a system-wide configuration and it will change appearence in other programs too."
-
-}
-
-post_upgrade() {
- # Only show information if upgrading from 4.0.6 or older
- if [ $(vercmp $2 4.0.6-1) -le 0 ]; then
- post_install
- fi
-}