summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlmartinez-mirror2021-04-09 00:09:58 -0500
committerlmartinez-mirror2021-04-09 00:09:58 -0500
commit9f4ccd6698e951455bfebec9700518b4b58e3b18 (patch)
tree749b0d8491fe697d5ccf63b985159517799c214a
parenta998598b72836d3d168e8edb6feef88de4507051 (diff)
downloadaur-9f4ccd6698e951455bfebec9700518b4b58e3b18.tar.gz
create unique names for sources
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD10
2 files changed, 9 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 918911fec0f0..6290cd96c21f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = zoxide-bin
pkgdesc = A fast cd command that learns your habits (binary release)
pkgver = 0.6.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/ajeetdsouza/zoxide
arch = x86_64
arch = armv7h
@@ -13,11 +13,11 @@ pkgbase = zoxide-bin
options = strip
source = https://raw.githubusercontent.com/ajeetdsouza/zoxide/v0.6.0/LICENSE
sha512sums = abf8fa83fc3e17f92046611974d837029da055eb53d5d17ac0453e6edef27ed172416376751be76833a2a54d28e1d173bb82635ff62ba51ebcca3733d51600c3
- source_x86_64 = zoxide::https://github.com/ajeetdsouza/zoxide/releases/download/v0.6.0/zoxide-x86_64-unknown-linux-gnu
+ source_x86_64 = zoxide-0.6.0-x86_64::https://github.com/ajeetdsouza/zoxide/releases/download/v0.6.0/zoxide-x86_64-unknown-linux-gnu
sha512sums_x86_64 = c45938296b8737581bd31098658f41290735c77761a089aaf763f466d439911a3d623cd46c32513bde06deb8e92ff003d127928f8b1bcca684910296a81d07b8
- source_armv7h = zoxide::https://github.com/ajeetdsouza/zoxide/releases/download/v0.6.0/zoxide-armv7-unknown-linux-gnueabihf
+ source_armv7h = zoxide-0.6.0-armv7h::https://github.com/ajeetdsouza/zoxide/releases/download/v0.6.0/zoxide-armv7-unknown-linux-gnueabihf
sha512sums_armv7h = 79a128a06f16507b915c6c60d9457220f265d6935ded48090d8514e88fdf9c4a805ffbcfd4a4e67b44bca68f7e418171c5a8c49babbaf5a1fbcab690892d23bc
- source_aarch64 = zoxide::https://github.com/ajeetdsouza/zoxide/releases/download/v0.6.0/zoxide-aarch64-unknown-linux-gnu
+ source_aarch64 = zoxide-0.6.0-aarch64::https://github.com/ajeetdsouza/zoxide/releases/download/v0.6.0/zoxide-aarch64-unknown-linux-gnu
sha512sums_aarch64 = 34017ce904c84f322ec7827422105500536d396bde73f245551819683137a3754c7b670830047a8c9efb14c70e933a82dd04c0d2450a98181bce7d69b2f582c8
pkgname = zoxide-bin
diff --git a/PKGBUILD b/PKGBUILD
index b72bf45845e5..944c910583a8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=zoxide-bin
_pkgname=zoxide
pkgver=0.6.0
-pkgrel=1
+pkgrel=2
pkgdesc='A fast cd command that learns your habits (binary release)'
arch=('x86_64' 'armv7h' 'aarch64')
url="https://github.com/ajeetdsouza/zoxide"
@@ -11,9 +11,9 @@ license=('MIT')
depends=('gcc-libs')
provides=('zoxide')
conflicts=('zoxide')
-source_x86_64=("${_pkgname}::${url}/releases/download/v${pkgver}/${_pkgname}-x86_64-unknown-linux-gnu")
-source_armv7h=("${_pkgname}::${url}/releases/download/v${pkgver}/${_pkgname}-armv7-unknown-linux-gnueabihf")
-source_aarch64=("${_pkgname}::${url}/releases/download/v${pkgver}/${_pkgname}-aarch64-unknown-linux-gnu")
+source_x86_64=("${_pkgname}-${pkgver}-x86_64::${url}/releases/download/v${pkgver}/${_pkgname}-x86_64-unknown-linux-gnu")
+source_armv7h=("${_pkgname}-${pkgver}-armv7h::${url}/releases/download/v${pkgver}/${_pkgname}-armv7-unknown-linux-gnueabihf")
+source_aarch64=("${_pkgname}-${pkgver}-aarch64::${url}/releases/download/v${pkgver}/${_pkgname}-aarch64-unknown-linux-gnu")
source=("https://raw.githubusercontent.com/ajeetdsouza/${_pkgname}/v${pkgver}/LICENSE")
sha512sums=('abf8fa83fc3e17f92046611974d837029da055eb53d5d17ac0453e6edef27ed172416376751be76833a2a54d28e1d173bb82635ff62ba51ebcca3733d51600c3')
sha512sums_x86_64=('c45938296b8737581bd31098658f41290735c77761a089aaf763f466d439911a3d623cd46c32513bde06deb8e92ff003d127928f8b1bcca684910296a81d07b8')
@@ -22,6 +22,6 @@ sha512sums_aarch64=('34017ce904c84f322ec7827422105500536d396bde73f24555181968313
options=(strip)
package() {
- install -Dm 755 -t "${pkgdir}/usr/bin" ${_pkgname}
+ install -Dm 755 "${_pkgname}-$pkgver-${CARCH}" "${pkgdir}/usr/bin/${_pkgname}"
install -Dm 644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}