summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBryn Edwards2016-06-13 09:55:26 +0100
committerBryn Edwards2016-06-13 09:55:26 +0100
commitc07de2f2ffd0f30233234124ed7c91bddf7386fa (patch)
treed3fa5f730657901437179a064b5cc4a31cdbce94
downloadaur-c07de2f2ffd0f30233234124ed7c91bddf7386fa.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD25
-rw-r--r--zplug.install4
3 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..eb8f40242aec
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = zplug
+ pkgdesc = A next-generation plugin manager for zsh
+ pkgver = 2.1.0
+ pkgrel = 1
+ url = http://zplug.sh
+ install = zplug.install
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = zsh
+ source = https://github.com/zplug/zplug/archive/2.1.0.tar.gz
+ sha1sums = 8ba1890003b31e84debe11f4ea6c79d850b8a2c0
+
+pkgname = zplug
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4f30da5fab00
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Bryn Edwards <bryn at openmailbox dot org>
+pkgname=zplug
+pkgver=2.1.0
+pkgrel=1
+pkgdesc="A next-generation plugin manager for zsh"
+arch=('any')
+url="http://zplug.sh"
+source=("https://github.com/$pkgname/$pkgname/archive/$pkgver.tar.gz")
+sha1sums=('8ba1890003b31e84debe11f4ea6c79d850b8a2c0')
+license=('MIT')
+depends=('zsh')
+makedepends=('git')
+install='zplug.install'
+
+package() {
+ cd $srcdir/$pkgname-$pkgver/
+ mkdir -p $pkgdir/usr/share/zsh/scripts/$pkgname/
+ cp -R ./{autoload,base,init.zsh,misc,zplug} $pkgdir/usr/share/zsh/scripts/$pkgname/
+
+ mkdir -p $pkgdir/usr/share/man
+ cp -R ./doc/man/* $pkgdir/usr/share/man/
+
+ mkdir -p $pkgdir/usr/share/licenses/zplug/
+ cp -R ./doc/LICENSE-MIT.txt $pkgdir/usr/share/licenses/zplug/
+}
diff --git a/zplug.install b/zplug.install
new file mode 100644
index 000000000000..565bc1c3a450
--- /dev/null
+++ b/zplug.install
@@ -0,0 +1,4 @@
+post_install() {
+ echo "To use zplug, include the following line in your .zshrc:
+ source /usr/share/zsh/scripts/zplug/zplug.zsh "
+}