summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMilk Brewster2020-03-23 17:58:54 +0000
committerMilk Brewster2020-03-23 17:58:54 +0000
commit6213bbd18b5539eb6070b1f8944c99a3ce445f63 (patch)
tree4d203a2cc6d9553065dfebd1d69527bfb7c6cdd6
downloadaur-6213bbd18b5539eb6070b1f8944c99a3ce445f63.tar.gz
initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD50
2 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ee66afbf7d6d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = zplugins.lv2-git
+ pkgdesc = Zrythm plugins for audio, MIDI and CV, including ZLFO, ZSaw, ZVerb and ZChords (debug)
+ pkgver = r36.444ae2d
+ pkgrel = 1
+ url = https://github.com/zrythm/ZPlugins
+ arch = x86_64
+ groups = lv2-plugins
+ license = GPL
+ makedepends = lv2lint
+ depends = glib2
+ depends = librsvg
+ depends = cairo
+ depends = librsvg
+ options = debug
+ options = !strip
+ source = zplugins::git+https://git.zrythm.org/git/zplugins
+ md5sums = SKIP
+
+pkgname = zplugins.lv2-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..298c9047440b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Maintainer: Milkii Brewster <milkii on Freenode IRC>
+maintaner="Milkii Brewster <milkii on Freenode IRC>"
+pkgname=zplugins.lv2-git
+pkgdesc="Zrythm plugins for audio, MIDI and CV, including ZLFO, ZSaw, ZVerb and ZChords (debug)"
+pkgver=r36.444ae2d
+pkgrel=1
+epoch=
+arch=(x86_64)
+url="https://github.com/zrythm/ZPlugins"
+license=(GPL)
+groups=(lv2-plugins)
+depends=("glib2" "librsvg" "cairo" "librsvg")
+makedepends=(lv2lint)
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=(debug !strip)
+install=
+changelog=
+source=(zplugins::git+https://git.zrythm.org/git/zplugins)
+noextract=()
+md5sums=('SKIP')
+
+pkgver() {
+ cd "zplugins"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+prepare() {
+ cd "zplugins"
+ cd ext/Soundpipe && CC=gcc make && cd ../..
+ meson build --prefix /usr
+}
+
+build() {
+ cd "zplugins"
+ # ./configure --prefix=/usr
+ ninja -C build
+}
+
+package() {
+ cd "zplugins"
+ DESTDIR="$pkgdir/" ninja -C build install
+}