summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGrigorii Horos2015-08-06 02:48:07 +0300
committerGrigorii Horos2015-08-06 02:48:07 +0300
commit4eb9e89fc6decc243dc78615b49857528c3a2042 (patch)
treed9742d5a9517ed6e75b0342d99d25b21a9e10b19
downloadaur-4eb9e89fc6decc243dc78615b49857528c3a2042.tar.gz
Initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD19
-rw-r--r--zpm.install5
3 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ce92b067d4dd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = zpm
+ pkgdesc = ZPM ( Zsh plugin manager ) is an yet another plugin manager for zsh similar to vim-plug
+ pkgver = 20150806
+ pkgrel = 1
+ url = https://github.com/horosgrisa/zpm
+ arch = any
+ license = LGPL3
+ options = !strip
+ source = zpm-20150806.tar.gz::https://github.com/horosgrisa/zpm/archive/0a2c31d11c53ea65e503f31e78604551aa26ecd7.tar.gz
+ sha256sums = e7e1da3313a84d57a48986c8498fc45431c0b025fb177ac2726d4c728bda3289
+
+pkgname = zpm
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2509d8849e02
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Grigorii Horos <horosgrisa@gmail.com>
+
+_git=0a2c31d11c53ea65e503f31e78604551aa26ecd7 # lastest commit 20150806
+pkgname=zpm
+pkgver=20150806
+pkgrel=1
+pkgdesc="ZPM ( Zsh plugin manager ) is an yet another plugin manager for zsh similar to vim-plug"
+arch=('any')
+url="https://github.com/horosgrisa/${pkgname}"
+license=('LGPL3')
+options=('!strip')
+source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/${_git}.tar.gz")
+sha256sums=('e7e1da3313a84d57a48986c8498fc45431c0b025fb177ac2726d4c728bda3289')
+
+package() {
+ install -d ${pkgdir}/usr/share/zpm
+ cp -r ${srcdir}/${pkgname}-${_git}/{plugins,zpm.zsh,zshrc-example} ${pkgdir}/usr/share/zpm
+ install -D -m644 ${srcdir}/${pkgname}-${_git}/LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+} \ No newline at end of file
diff --git a/zpm.install b/zpm.install
new file mode 100644
index 000000000000..97c327cf60cf
--- /dev/null
+++ b/zpm.install
@@ -0,0 +1,5 @@
+post_install() {
+ echo "If you want to enable zpm, execute
+$ cp /usr/share/zpm/zshrc-example ~/.zshrc
+ "
+} \ No newline at end of file